Jump to content

Unable to delete Report Output in JasperServer 5.6


djsiders

Recommended Posts

I am in the process of attempting an update to JasperServer 5.6   I have successfully configured and built the application and got it to start on my machine.  I built a simple report and setup a scheduled job for that report, and all worked fine (emailed report, created report in repository, etc.) 

After running, I went to the repository folder where the report output files were stored (CSV and PDF) and tried to delete, but no option is given.  When I select those files, the buttons at the top stay greyed out.  Note that since I was just testing, I used the same folder for the Jasper Report and the report output files, not sure if that matters.  When I select the Jasper Report in the same folder, I get the delete option (button enabled). 

I have played with permissions on the folder as well, no luck.  I am working as user jasperadmin, and have not made any server config changes via the UI (permissions, etc.) other than as noted above.

 

 

Link to comment
Share on other sites

  • 1 month later...
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • 4 months later...
The JS is missing "Utils" scope in getInitConfiguration.  The original source is:

 

    var Utils = {

    restOfString: function(str, fromStr) {

        var from = str.lastIndexOf(fromStr) + fromStr.length;

        return str.substring(from, str.length).trim();

    },

    getInitOptions: function () {

        return localContext.rsInitOptions || __jrsConfigs__.repositorySearch["localContext"].rsInitOptions;

    },

    getInitConfiguration: function () {

        return getInitOptions().configuration;

    }

};

 

Just change "return getInitOptions().configuration;" to get "return Utils.getInitOptions().configuration;"

 

You'll have to make this change in the optimized version of the script (optimized-scripts/results.page.js).  Fortunately there are only two occurrences of getInitOptions so it's easy to find and fix the correct one.

 

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...