Jump to content
Changes to the Jaspersoft community edition download ×

Not able to select/create a new report in iReport Designer 5.0.4


k_tripura
Go to solution Solved by k_tripura,

Recommended Posts

Hi,

I installed Jaspersoft iReport Designer 5.0.4 in my local system in ':Program Files (x86)JaspersoftiReport-5.0.4' in my Windows 7, 64Bit machine.

First I got "Cannot find java exe."
      "Neither (null)jrebinjava.exe nor (null)vinjava.exe exists" error

Then I installed JDK latest version at ':Program Files (x86)Javajdk1.7.0_11B:Program Files (x86)Javajdk1.7.0_11'  and then

I added jdkhome="B:/Program Files (x86)/Java/jdk1.7.0_11" to ':Program Files (x86)JaspersoftiReport-5.0.4etcireport.conf'  file and reloaded iReport.

Now it loaded without any errors and it is perfectly fine.

In order to connect to Ms Sql Server 2008 db

I downloaded JTDF drivers from  http://jtds.sourceforge.net/  and established the db connection.

HERE COMES MY ISSUE::

Now, I clicked on Create a new report. in  Home Screen of Jasper report ( went to File ->New, tried both) , new file window launched, by highlighting Reports..

But - Here comes my problem, I don't  have any report to select on the right side or non of my buttons 'Open this Tempate' or 'Launch Report Wizard' are doing anything ... the only button that works is cancel button.

I tried navigating to other types on the left, like style etc but everything appears to be blank and finsh button does nothing..

iReport_Issue.png.0050435536e3f20439a2c336847c29d4.png

How do I fix this issue and create a new report??

Thanks for the help.

 

 

 

 

 

 

 

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Hi
Thank you for the reply

I tried un-installing Jasper and reinstalling it.
Also I un-installed and re-installed JDK latest version in default Directory

Now I am able to see Report Templates, BUT -- I am NOT ABLE to Click "Open this Template" OR "Launch Report Wizard"

What else is the possible issue and how can I fix this

Link to comment
Share on other sites

  • Solution

Hello  oesina, your comment helped me to rethink and

I am able to fix it myself.

I tried uninstalling everything, both JDK and Jasper iReport( all versions), cleaned registry and re-installed everything in the root (ro C directory) of my machine rather than different directory level and added Java_Home, which finally fixed all the issues

Thanku

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

I'm having this problem yet, I'm not able to create or select reports wizard, i I uninstalled the ireport and delete all the version and still not working

besides, I downloaded the latest version 5.1 and i have the same problem

is there another way to fix this issue?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...