Jump to content
Changes to the Jaspersoft community edition download ×

Problems with SaxParser


2004 IR Help

Recommended Posts

By: LeeBar - leebar

Problems with SaxParser

2005-05-19 09:34

Hi

 

When I run my application in IDEA, everything works fine. As soon as I run it on the command line, I get the following error:

 

[Digester:1439] Parse Error at line 1 column 565: Element type "import" must be declared.

[java] org.xml.sax.SAXParseException: Element type "import" must be declared...

 

In the project I'm using xerces-2_5_0 - I assume that IDEA has an own XML Parser library which will do the job of parsing the report when I run the application in IDEA.

My question is: should the xerces-2_5_0 parser not also work since it implements JAXP 1.2? Does anyone have similar problems?

 

Thank you in advance!

 

Lee

 

 

 

 

By: LeeBar - leebar

RE: Problems with SaxParser

2005-05-19 15:47

I solved the problem - the existing application had an older jasperreports.jar version. After updating to jasperreports-0.6.7.jar it worked just fine... Is there any reason not to use this newest jasperreports version?

 

Thanks!

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...