Jump to content
Changes to the Jaspersoft community edition download ×

Help desperately needed


Recommended Posts

I have posted in here about my situation already but am in desperate need of help.


I am trying to display a pdf report to the browser on my pc (interim step before moving to as/400). I am using Java servlet to try and do this.


I have code within my servlet that has successfully executed and displayed pdf to browser. I used iReports version 1.2.3 to create and compile the jasper file used as template.


Having seen version 1.2.4 then version 1.2.5 released I have tried unsuccessfully to achieve the same results. Obviously (at least to me lol) it is a version issue. iReports works as expected and all versions display report to me when compiling. My guess is that I do not have the files (jars) needed in my classpath/lib that are needed to display these reports compiled in newer versions.


I am at a new job, learning new technology (Java) and was given the task of evaluating JasperReports and iReports as a path to our building online reports. Due to my initial success with previous versions I exclaimed the benefits of choosing these technologies. Then reality set in and now frustration is setting in trying to get these new versions running and having no success. My boss is frustrated and does not understand why it is taking so long. I have googled till I can't google no more, and admittedly may have missed the forum/site needed to assist me.


I am have tried to resolve the issue on my own, but admit I need the help of more experienced peers. I still believe that JasperReports with iReports is our best solution just can't get over this hump. Some success would even maybe merit me being able to get the documentation.


What jar files do I need to have in the lib directory?

What jar files do I need to add to the classpath?

where do the java files created when compiling go?

Do I even need them if I am not doing any customization from within them yet?


I know everyone has their own projects to work on and help when they can, but as soon as someone can any help would be greatly appreciated.


With most Respect,



Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

From your Jasper report install directory you can see a directory dist. Copy the two jars into your web-inf/lib and that should resolve your classpath issues.


And also you may want to copy all the jars under C:jasperreports-1.2.5lib into your web-inflib directory. That way you wont miss any needed jars


If you get any erros ..it would be helpful you can post the exact error text. So someone can help you pinpoint the problem.


Hope the above works...



Post edited by: vij, at: 2006/07/21 20:15

Link to comment
Share on other sites



Thank you for your help.


I cleared out the lib folder for my Webapp and readded the files that Eclipse told me I was missing and used the files from the dist folder for 1.2.5.


This time I at least got an error that stated a method for building a chart was not found. So I added the JFreeChart jar file and I was back at empty page being displayed.


So I threw in everything and the kitchen sink from the iReports 1.2.5 lib folder into my webapp lib folder and shazam it worked.


Hopefully Jaspersoft/iReports/JasperReports will come out with a distribution list of the basic files needed to run reports from Browser or other scenarios. I'm new to Java and OpenSource applications so not used to the lack of documentation provided users.


But again thank you vij for taking time to help me, it is greatly appreciated.



Link to comment
Share on other sites

I'm sure you'll find as you learn more about Java in the future you'll probably already have most of the libraries installed. I know for us all I had to do was copy the jasper and jfree libraries into our tomcat/lib dir and everything worked.
Link to comment
Share on other sites

  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...