Jump to content
Changes to the Jaspersoft community edition download ×

iReport Install Problem: "Cannot find Java.exe"


Recommended Posts

Hi Everyone -

I'm new to iReport... I have a new Windows 7 PC  with very few programs installed (except MS Office 2007, Visual Studio 2008 and Visual Foxpro 9.2 )machine... I installed the latest build of iReport (Windows stand-alone version).

Everything appeared to install correctly ... however.. when I attempted to run the program, I get the following error:

"Cannot find java exe."

"Neither (null)\jre\bin\java.exe nor (null)\vin\java.exe exists"

My question is:  Even though I installed the "stand-alone" version ... do I have-to install additional files? 

If so... which, and where can I find them?

Thanks for any help you can give me!

Link to comment
Share on other sites

  • Replies 16
  • Created
  • Last Reply

Top Posters In This Topic

Thank you very much for your response...

I had to "ADD" the Environmental variable... to the system properties... as it was not in the list at all ... however... nothing happened...

When I try to run iReport... I still get the "Cannot find Java.exe..." error.

Moreover... I don't even have the directory referenced in the environmental variable you suggested I add... iReport didn't install that directory (see attached picture of my directory) ...

Do I need to install JasperServer and/or JasperReports, in addition to iReport... to get the necessary support files to run iReport?

Thanks again ... !

Post Edited by tomking23 at 02/15/2010 03:24
Link to comment
Share on other sites

  • 4 months later...
  • 11 months later...
  • 5 months later...

I'm using win 7 64bit. I installed iReport 4.5 (release on today - 8 Dec 2011) & it brings to me the same result.
As what I see:/tools/fckeditor/editor/images/smiley/msn/shades_smile.gif

The iReport (in "C:Program Files (x86)JaspersoftiReport-4.5.0binireport.exe" for my case) look up absolute name of jre & jdk folders (not something like jre7 or jdk1.7.0_01 folder in installed Java folder, in this case I install the Java Platform (JDK) 7u1)

+ Solution

1st way:
set JAVA_HOME in system variables to your installed Java folder but you have to be sure there are absoulte jre & jdk folders not the jre_x/jdk_x where x is the verion of java runtime as stated above)

I prefer the 2nd way which is more flexible & can allow to use multiple java runtime

2nd way:

Set up the jdkhome in (installed Jaspersoft folder)iReport-4.5.0etcireport.conf to your installed Java folder.Example for my case:

step1: create a new folder, eg: "C:Program FilesJavaforJasper45"

step2: copy jre7 & jdk1.7.0_01 to that folder then rename to jre & jdk repectively

step3: add this line in the ireport.conf

jdkhome="c:Program FilesJavaforJasper45"

/tools/fckeditor/editor/images/smiley/msn/lightbulb.gifThen it works for me



Post Edited by aoopvn at 12/09/2011 06:02

Post Edited by aoopvn at 12/09/2011 06:03
Link to comment
Share on other sites

  • 1 year later...
  • 7 months later...
  • 11 months later...
  • 7 months later...
  • 4 months later...
  • 11 months later...
  • 2 months later...


This is because it needs the JRE (Java Runtime Enviroment) which is not installed on your pc or if it is installed then the environment variables are not set.


Hard = Set the environment variables which most people don't know i dont mean every one so dont get me wrong.

Easy = Install the latest JRE from this link https://www.java.com/en/download/ 

The installation will set every thing and you are done and good to go.

Link to comment
Share on other sites

  • 3 months later...
  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...