Jump to content
Changes to the Jaspersoft community edition download ×

Display Report on JSP


ktrinad

Recommended Posts

By: Eric Tan - neltan

Display Report on JSP

2003-02-17 20:53

Hi,

I'm using RH8 + JSP.

Each time I reboot my local machine/server, it will display error (below) when generating jasper report.

If I restart tomcat in local machine, it will generate report successfully. However, when restarting in server, it won't work.

 

Strange!!!

 

 

org.apache.jasper.JasperException: Can't connect to X11 window server using 'erictan:0.0' as the value of the DISPLAY variable.

at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:248)

at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:295)

at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:684)

at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:432)

at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:356)

at servlet.process.gotoPage(process.java:143)

at servlet.process.processRequest(process.java:100)

at servlet.process.doPost(process.java:130)

 

 

By: Boris Klug - bklug

RE: Display Report on JSP

2003-02-18 00:05

See the top message of the stack trace:

Can't connect to X11 window server using 'erictan:0.0' as the value of the DISPLAY variable.

 

My guess: When you boot your machine, Java (=tomcat) does not get the shell variable DISPLAY which tells X on which display X programs should direct the output.

 

Think about using JDK 1.4.x and the headless support - with this you do not longer need an X server at all. Search the forums for how to setup headless support.

 

 

By: Eric Tan - neltan

RE: Display Report on JSP

2003-02-19 18:30

Hi bklug,

I've read your message.

 

To use the headless support in JDK 1.4.1 all you have to do is setting the java system property java.awt.headless to true, e.g. with "java -Djava.awt.headless=true theclass".

 

But Tomcat will compile/run jsp for me. How can I tell tomcat to "java -Djava.awt.headless=true theclass"?

 

 

By: Frans Thamura - fthamura

RE: Display Report on JSP

2004-02-01 04:38

How to set it, If I want to use Tomcat?

 

 

 

 

By: Tom Koshy - tomkoshy

RE: Display Report on JSP

2004-03-07 19:38

When you are starting tomcat you can add these parameters in JAVA_OPTS variable. Check inside catalina.sh startup file for your server.

 

Here is what I am using

JAVA_OPTS="$JAVA_OPTS -server -Dsite.name=bmgonline.com -Djava.awt.headless=true -Xms32m -Xmx64m"; export JAVA_OPTS

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...