Jump to content
Changes to the Jaspersoft community edition download ×

problem with JRXmlWriter.writeReport(...)


Recommended Posts

By: Dirk Rost - appshare

problem with JRXmlWriter.writeReport(...)

2003-11-23 07:42

Hi,

 

I've some problems with the JRXmlWriter.writeReport(...)

 

I read the original with

 

File lvXmlTemplate = new File(lvSContext.getRealPath("/configuration/reports/" + "CoWebTemplate.xml"));

JasperDesign lvDesign = JRXmlLoader.load(lvXmlTemplate);

 

And that ist the source:

 

<rectangle>

<reportElement mode="Transparent" x="0" y="0" width="782" height="50" forecolor="#00FF40" backcolor="#FFFFFF" positionType="FixRelativeToTop" isPrintRepeatedValues="true" isRemoveLineWhenBlank="false" isPrintInFirstWholeBand="false" isPrintWhenDetailOverflows="false"/>

<graphicElement stretchType="NoStretch" pen="Thin" fill="Solid"/>

</rectangle>

 

Now i use JRXmlWriter to save it to another name, and here is the result:

 

 

<rectangle>

<reportElement mode="Transparent" x="0" y="0" width="782" height="50" forecolor="#ff40"/>

<graphicElement pen="Thin"/>

</rectangle>

 

Most attributes are missing and there occured an error for the color.

 

Any ideas? Thanks a lot

 

Dirk

 

 

 

 

By: Teodor Danciu - teodord

RE: problem with JRXmlWriter.writeReport(...)

2003-11-28 13:46

 

Hi,

 

In the XML output, all the attributes that have values

equal to the default values are missing.

This is for minimizing the output.

 

As for the color, there are two zeros missing,

but they are not significant

(they are removed from the left).

 

I hope this helps.

Teodor

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...