Jump to content
Changes to the Jaspersoft community edition download ×

JasperReports on AS400

Recommended Posts

By: LuxCed - luxced

JasperReports on AS400

2003-08-29 01:17

Hi All,

I'm tryng to run JasperReports on IBM's AS400 platform, and I would like to know if someone of you has already tried to do the same.

When I run a demo (modified to retrieve data from a db on AS400) on w2k platform, always is ok.

When I run it on AS400, I receive this error :



[java] java.lang.Error: Could not find class: com.ibm.rawt2.ahost.java.awt.AHGraphicsEnvironment

[java] at java/lang/Throwable.<init>(Throwable.java:195)

[java] at java/lang/Error.<init>(Error.java:49)

[java] at java/awt/GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:68)

[java] at dori/jasper/engine/fill/JRBaseFiller.<clinit>(JRBaseFiller.java:120)

[java] at dori/jasper/engine/fill/JRFiller.fillReport(JRFiller.java:99)

[java] at dori/jasper/engine/JasperFillManager.fillReport(JasperFillManager.java:219)

[java] at dori/jasper/engine/JasperFillManager.fillReportToFile(JasperFillManager.java:140)

[java] at dori/jasper/engine/JasperFillManager.fillReportToFile(JasperFillManager.java:101)

[java] at QueryApp.main(QueryApp.java:109)

[java] Java Result: 1





Thanks in advance







By: Ryan Johnson - delscovich

RE: JasperReports on AS400

2003-08-29 09:08

Sounds to me like you're trying to run headless. Search for "headless" and read the other posts on the issue



Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...