Jump to content
Changes to the Jaspersoft community edition download ×

Subreport doesn't show up on the second page


Recommended Posts

By: Marianna - marianna_kr

Subreport doesn't show up on the second page

2003-07-31 19:56

Hello everyone!!

I searched this forum but couldn't fine what i am looking for.

Here is my problem ... I have a subreport that uses custom datasource.. I'm passing this datasource as a parameter to the main report and then from the main report to the subreport. My subreport has only one row it it and it' should be displayed on every page, but it only displays on the first one ... Any ideas ?

 

Thanks, Marianna

 

 

 

 

By: Ryan Johnson - delscovich

RE: Subreport doesn't show up on the second page

2003-08-01 09:41

Datasources only get used once. You'll need to have a different (possibly cloned) copy for each time you need it to show, or else use scriptlets somehow to reset it.

 

Ryan

 

 

 

 

By: juan david vergara perez - jvergara

RE: Subreport doesn't show up on the second page

2003-08-01 12:16

See the JRRewindableDataSource, if you can to implement the moveFirst() method, you've got the solution.

 

the JRRewindableDataSource has became with the version 0.5.0.

 

Bye bye!

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...