Jump to content
Changes to the Jaspersoft community edition download ×

prob printing japanese report in netscape


Recommended Posts

By: padmini - padmini

prob printing japanese report in netscape

2003-06-18 22:57

Hi ,

 

I have a html report which has some japanese characters. The characters are displayed correctly in the netscape 4.7 browser but when i print the report the japanese characters are all junk . The same works fine when printed with IE5.5 .

I am working with jasper version 0.4.4 which uses itext version 0.9.2

I tried changing itext to version 0.9.6 then also the same problem.

this is how I have defined the fonts

<?xml version="1.0" ?>

<!DOCTYPE jasperReport PUBLIC "-//JasperReports//DTD Report Design//EN" "http://jasperreports.sourceforge.net/dtds/jasperreport.dtd">

 

 

 

<reportFont name="Gothic_Normal" isDefault="true" fontName="MS UI Gothic" size="12" pdfFontName="HeiseiKakuGo-W5" pdfEncoding="UniJIS-UCS2-H"/>

<reportFont name="Gothic_Bold" isDefault="false" fontName="MS UI Gothic" size="12" isBold="true" pdfFontName="HeiseiKakuGo-W5" pdfEncoding="UniJIS-UCS2-H"/>

<reportFont name="Gothic_Italic" isDefault="false" fontName="MS UI Gothic" size="12" isItalic="true" pdfFontName="HeiseiKakuGo-W5" pdfEncoding="UniJIS-UCS2-H"/>

 

can anyone please suggest a sol as soon as possible

 

Thanks

Padmini

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...