Jump to content
Changes to the Jaspersoft community edition download ×

Using JasperReports at WebSphere 6.1


wso

Recommended Posts

Hi all,

 

I'm new to Application Development. I used JBoss/Eclipse with Struts framework and Jasper Assistance to created report. Currently, I'm moving my JBoss/Eclipse environment to WebSphere Application Server 6.1. Now after I plugged in Struts and JasperReport .jar to shared libraries into WebSphere. My application is worked, but my application cannot create reports (PDF page output). I doubled check my JasperReports .jar file; it's the same JasperReports .jar as I used in JBoss/Eclipse Jasper Assistance. The SystemLog told me calling Created Report Action is worked, yet the server jump over Jasper and display anything. Did I missing anything? or Do I need any third party app. to make WAS understand JasperReports?

 

The following coding which is my Application.xml file. I hided out ejb, for i don't use ejb, so WAS won't get confuse. I checked my .war file, it has everything suppose to be included .jasper and .jrxml files. Now I'm using JasperReports, do I have to separate out .jasper and .jrxml files to import to WAS Server, instead of import the whole .war. Thanks

 

william

 

WAS side:

WebSphere 6.1.0.7

Struts 1.2.7

JasperReports 1.2.4

 

Jboss/Eclipse:

JBossIDE for Eclipse Version: 2.0.0

Eclipse JAVA Development 3.2

J2EE Standard Tools 1.5.1

Struts 1.2.7

Jasper Assistant_2.2.0_Eclipse3.2 (using JasperReports 1.2.4)

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE application PUBLIC

"-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN"

"http://java.sun.com/dtd/application_1_3.dtd">

<application>

<display-name>TeamAccount</display-name><!--

<module>

<ejb>TeamAccountEJB.jar</ejb>

</module>

--><module>

<web>

<web-uri>TeamAccountWeb.war</web-uri>

<context-root>/TeamAccount</context-root>

</web>

</module>

</application>

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...