Jump to content
Changes to the Jaspersoft community edition download ×

Spaces in Field Name


Recommended Posts

By: Ed B - thechocolatay

Spaces in Field Name

2003-04-24 08:33

I am trying to generate a report from a table that has spaces in the field names. I get an error beacaus eof the spaces, and when I put in the mySQL syntax I still get errors see my example below. I cannot remove the spaces because I do not own the data source. I would appreciate any help.

 

FieldName - Works

Field Name - Errors

`Field Name` - Errors

 

 

 

 

By: Chuck Deal - cdeal

RE: Spaces in Field Name

2003-04-24 09:05

I understand that you don't have access to the table, but do you have the ability to write a query against it?

 

If so, then could you alias the offending fields and use the new query as the basis of the report?

 

I just thought I would toss that out there, I don't know how to solve the problem using Jasper conventions, off the top of my head.

 

 

 

 

By: Ed B - thechocolatay

RE: Spaces in Field Name

2003-04-26 09:13

Thanks for your help! I did not think of using aliases, I tried it out and it works.

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...