Jump to content
Changes to the Jaspersoft community edition download ×

Issue with MSFT Word RTF formating v1.3.1->1.3.3


zethris

Recommended Posts

We have been using Jasper in our application for well over 2 years now, in fact, it has been such a staple for us it isn't until now that we are working to upgrade to the latest/er version from jasper reports v1.0.2

 

our report sizes have increased considerably, and iReport seems to work best with the later version to modify the design of some of our reports.

 

After upgrading to 1.3.2 however, there seems to be some strange behavior when rendering a jasper report from our Java/XML/MySQL application.

 

1.0.2 will render reports in word with very clean accuracy of the row's and fields of data we output. No line breakages, clean rows and columns. It worked well. But the data manipulation and speed isn't there in 1.0.2 as we see with 1.3.2.

 

What happens is when the jasper report renders and outputs to Microsoft word as a .doc file some of the rows are broken up, the columns don't line up properly, it just isn't like it was before.

 

Do some of you "old timers" know what I am talking about by chance?

 

I have not been with the company for as long as they have been using Jasper Reports so I have not been "in the loop" on these boards for that long to find out if there have been any issues since 1.0.2 was released with output to microsoft word.

 

The strange thing is, the beautiful render job that 1.0.2 did works on the latest office software and also open office, but this issue of broken rows, columns, etc only seems to happen with the later versions.

 

What may have changed? What do you think I may have forgotten? I have searched these forums extensively, but I have not found what I needed to resolve this.

 

I use iReport to create the master report with multiple subreports that queries SQL. In the folder that stores the jars, I replaced the .jar of the 1.0.2 with the 1.3.2. Might I be forgetting something?

 

Thanks in advance! I will attach a screenshot and also a sample .jrxml file

 

-J [file name=InvoiceDetailPortrait.jrxml size=15141]http://www.jasperforge.org/components/com_joomlaboard/uploaded/files/InvoiceDetailPortrait.jrxml%5B/file] size=400]http://www.jasperforge.org/components/com_joomlaboard/uploaded/images/reportcap1_3_2a.jpg

 

Post edited by: zethris, at: 2007/04/27 22:05

 

Post edited by: zethris, at: 2007/04/30 14:31

 

Post edited by: zethris, at: 2007/04/30 15:18

Post edited by: zethris, at: 2007/05/23 13:02

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

I posted this on Friday and was hoping someone might happen by and have a possible answer. I still do not have one as I can't find if I need to be more specific in what I am specifying as an output where currently I am just using net.sf.jasperreports.engine.export.JRRtfExporter

 

Has something changed since 1.0.2 that I can't seem to find documentation about?

 

It seems that with 1.3.2 the RTF output is different and not as compatible with MS Word 6.0, 2003 and XP as it once was, which is kind of weird.

 

Any ideas? I am continuing to try to sleuth this down, but I hope that someone might know what changed, or what I need to do to tighten things up as they once were.

Link to comment
Share on other sites

Hi,

 

The only sample you've attached contains some subreports and cannot be tested until its information is not completed. Please try to attach a simplified, self consistent sample, which could reproduce your problem. Running the rtf export on other samples didn't get such errors.

 

Thank you,

sanda

Link to comment
Share on other sites

  • 2 weeks later...

Hi, again!

 

You were definitely right. Sorry about this quite long period without any answer, I was involved in other list of TODO things.

So, your problem is now solved, I put together all good things from 1.3.1 and 1.3.2 versions, and all those misalignments you complaint about were disappeared.

I hope the next release of JasperReports will show you a better and powerful reporting tool.

 

Thank you,

sanda

Link to comment
Share on other sites

great!

 

I hope so too.

 

I have a hunch that part of why the file sizes were so much smaller was because of how it was rendering the RTF in word and open office. But I do hope that, that wasn't the case as 1.3.2 and 1.3.3 cut the file size and render time down by over half. That is magic for a large report which we now do regularly as the business has grown.

 

Thank you for your time and care in this matter.

 

-Z

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...