Jump to content
Changes to the Jaspersoft community edition download ×

Result cached, dB query giving in correct result.


malini

Recommended Posts

Hi All, I am getting a very weird error.my Report Query (Oracle 9i database as the datasource)is givng very different result when I run using iReport.Query :SELECT COUNT(*)AS FULL_ELIGSFROM ELIG_TMP_TABLE WHERE MONTHS = 12Running this query in Oracle sql developer gives FULL_ELIGS=3953and running the same query in iRport gives FULL_ELIGS=19765i.e 5xFULL_ELIGs correct value.the ireport run was giving 3 time the FULL_ELIGS correct value 1st, then 4 times and 5 now...looks like it is caching data some place and giving me a computed result.How and where can i check if the result is indeed being cached.[color=#FF0000]NOTE: I am setting isUsingCache=False, it's still not clearing up the data...[/color]Any help greatly appriciated.Thanks,MaliniPost edited by: malini, at: 2007/03/15 19:14

 

Post edited by: malini, at: 2007/03/17 14:57

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...