Jump to content

not loading sub-reports...

Recommended Posts

By: Adriana Mestrinelli Paranhos - jasperdri

not loading sub-reports...

2003-03-05 12:42

Hello everyone..


I have a report with sub-report....when I run it with iReport, everything goes OK.....

but when I try to run it within my app, occurs an error saying that it can´t find the .jasper file from my sub-report...but this file is in the same directory from my app....


how can i solve this problem??







By: juan david vergara perez - jvergara

RE: not loading sub-reports...

2003-03-05 13:39

i solved the same problem, given the full path of the jasper template for the sub report.

for example( unix)








By: Teodor Danciu - teodord

RE: not loading sub-reports...

2003-03-25 13:35




When you supply the name of the master report,

you probably use a relative path or an absolute one.

But in the <subreportExpression> you have to use

the same location, because the engine does not

search relative to the master report directory.

This is not a very good approach.


The best way is to put the directory containing the

report templates into the classpath.

If you put the .jasper files in a structure like this:





You the add the "classes" directory to the

classpath and the subreport expression could be:


<subreportExpression class="java.lang.String">




I hope this helps.


Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...