Jump to content
Changes to the Jaspersoft community edition download ×

iReport 1.2.5 subreport compile error


wolf

Recommended Posts

newbie to ireport and jasper (1.2.5),

running on win-xp

 

no problem to have a single report with db-connection

then i builded up a subreport by iReport (whats inserted as an element of a band

 

cant compile the subreport separately ,

always an error occurs :

Code:

Compiling to file... .gl_testrechnung1_subreport0.jasper -> C:JasperSoftiReport-1.2.5classic.java
Errors compiling .gl_testrechnung1_subreport0.jasper!
it.businesslogic.ireport.ReportClassLoader@1d95624 net.sf.jasperreports.engine.JRException: Report design not valid : 1. Warning : Element bottom reaches outside band area : y=0 height=1 band-height=0 at net.sf.jasperreports.engine.design.JRAbstractCompiler.verifyDesign(JRAbstractCompiler.java:266) at net.sf.jasperreports.engine.design.JRAbstractCompiler.compileReport(JRAbstractCompiler.java:143) at net.sf.jasperreports.engine.design.JRDefaultCompiler.compileReport(JRDefaultCompiler.java:105) at net.sf.jasperreports.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:127) at net.sf.jasperreports.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:109) at it.businesslogic.ireport.IReportCompiler.run(IReportCompiler.java:478) at java.lang.Thread.run(Unknown Source)
Compilation running time : 78

the sub-report-dimension ive coorected after this err-message to a size less than the band in main-reports anyways

 

if i try to run the main-report error message tells that subreport is not found..

 

what to do now ?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

and there is an additional problem with

types of parameters with iReport 1.2.5 :

 

Code:

SELECT * FROM rechnung WHERE rg_nr = $P{P_RGNR}

 

rg_nr is of type int(11) in mysql

if i set Parameter P_RGNR as Integer,

i'll get an "casting" error :

 

Error filling print...

net.sf.jasperreports.engine.JRException:

Incompatible java.lang.Integer value assigned

to parameter P_RGNR

 

if parameter is set as "String" main-report works.

but why, with the SQL i'll assume to use int and not String !

 

any subreport with the same parameter will raise

the descripted error

 

 

i'll dont buy documentation as long as these simple things dont work properly and intuitive !

Link to comment
Share on other sites

okay,

with release 1.2.6 of iReport generating and calling

a subreport seems solved, no longer "subreport-not found"-error !

and parameter-values could be transported to subreport,

that fine so far !

 

the gui of this relase seems to be optimized !

 

but the parameter-type-problem isnt solved,

hope this will be possible soon..

 

so i can look to pay the latest docs ! thanks !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...