Jump to content
Changes to the Jaspersoft community edition download ×

error loading images from jasperserver repo


ktrinad

Recommended Posts

By: YSutarko - ysutarko

error loading images from jasperserver repo

2006-07-12 18:19

hi,

i've tried following the jasperintel userguide (the 8mb one), so far its a success, but when it comes to images, whenever i tried to drag an image from the repository to the report, when compile this error occured:

 

Error filling print...

net.sf.jasperreports.engine.JRException: Image not found : repo:/images/JRLogo at net.sf.jasperreports.engine.util.JRImageLoader.loadImageDataFromLocation(JRImageLoader.java:166) at net.sf.jasperreports.engine.JRImageRenderer.getInstance(JRImageRenderer.java:190) at net.sf.jasperreports.engine.fill.JRFillImage.evaluateImage(JRFillImage.java:471) at net.sf.jasperreports.engine.fill.JRFillImage.evaluate(JRFillImage.java:420) at net.sf.jasperreports.engine.fill.JRFillElementContainer.evaluate(JRFillElementContainer.java:277) at net.sf.jasperreports.engine.fill.JRFillBand.evaluate(JRFillBand.java:399) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillSummarySamePage(JRVerticalFiller.java:834) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillSummary(JRVerticalFiller.java:768) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReportEnd(JRVerticalFiller.java:259) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:135) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:750) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:647) at net.sf.jasperreports.engine.fill.JRFiller.fillReport(JRFiller.java:63) at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:402) at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillManager.java:234) at it.businesslogic.ireport.IReportCompiler.run(IReportCompiler.java:716) at java.lang.Thread.run(Thread.java:595)

Print not filled. Try to use an EmptyDataSource...!

 

is this maybe.. a bug? sorry for asking to much..

 

thanks

yusuf

 

 

By: Lucian Chirita - lucianc

RE: error loading images from jasperserver re

2006-07-13 02:13

I don't think you should directly run repository reports in iReport like you do with local reports. You have to first upload them to the repository and then run them on the server (I think there is a button for this in the repository browser).

 

HTH,

Lucian

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...