Jump to content
Changes to the Jaspersoft community edition download ×

iReport plugin for JasperServer


ktrinad

Recommended Posts

By: Maurizio D. - mdecolle

iReport plugin for JasperServer

2006-05-25 02:07

I have installed JasperServer, iReport 1.2.2 and the plugin. Everything went smoothly, including the installation of the JasperServer webservice, but when I try to connect to the repository from iReport I get a "bad credentials" error message. I have double checked each step and re-installed the whole thing more than one time but to no avail.

Any suggestions?

Thanks in advance.

Maurizio

 

 

By: Giulio Toffoli - gt78

RE: iReport plugin for JasperServer

2006-05-25 04:24

 

Hi Maurizio,

 

there is a bug in the current version of the plugin: try to exchange username and password in the plugin server settings. Currently the username is taken as password and vice versa.

 

Giulio

 

 

 

 

By: Maurizio D. - mdecolle

RE: iReport plugin for JasperServer

2006-05-25 06:06

Hi Giulio

 

I feel a little bit silly ... an italian writing to another italian in english ... but so the entire thread is accessible also to non italian speaking people.

I've exchanged the username and password and now the connection works. Thanks for your help.

 

Maurizio

 

 

By: Michael Calabrese - m2calabr

RE: iReport plugin for JasperServer

2006-05-25 06:13

Thank you from us non-Italian readers. It is greatly appreated.

 

 

By: Maurizio D. - mdecolle

RE: iReport plugin for JasperServer

2006-05-26 04:46

Another subject on the same thread ...

I'm still experimenting with JasperServer and the plugin for iReport. I've succesfully integrated into jasperServer both some existing reports (developed previously) and also some new ones (written from scratch). Now I'm facing a strange problem: I've tried to add to the repository a report using a rather complex layout and when I try to open it into iReport all I get is an almost empty layout ... it looks like all the layout elements are shrink into the upper left corner of the layout itself. The report uses images, non standard fonts, a scriptlet and has some graphic elements in the background band.

Please, feel free to ask for any kind of additional info.

 

Maurizio

Link to comment
Share on other sites

  • 2 years later...
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi All,

I have installed JasperServer 3.0 along with iReport. Every thing is working fine except the JasperServer Plugin in iReport.

I am not able to connect to JasperServer through iReport.

While starting the iReport, I am getting the following error:

 

Exception in thread "AWT-EventQueue-0" java.lang.IllegalAccessError: 

tried to access class it.businesslogic.ireport.plugin.checkupdate.CheckUpdate$1 from class

it.businesslogic.ireport.plugin.checkupdate.CheckUpdate

 

Any lead is appreciated.....

Kindly help me....

Thanks in advance.

~Sheeva

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...