Jump to content
Changes to the Jaspersoft community edition download ×

Errors after moving from 0.5.2 to 0.5.3


2006 IR Open Dicussion

Recommended Posts

By: creonnoir - creonnoir

Errors after moving from 0.5.2 to 0.5.3

2006-01-15 21:59

I've got a web app running under sun appserver that delivers pdf reports using jasperreports. After moving to 0.5.3 I get an odd error: error loading expression class:testresults_1137384920305_478627.

 

The name of the report is testresults and I've noticed that when I compile and run the report in ireport, instead of having testresults.java I end up with testresults_1137384920305_478627.java. The testresults.jasper file also contains the added numbers inside, but the name of the file is still testresults.jasper.

 

Does anyone know why this happens? Or better yet how to fix it. I don't understand why the report displays in ireport but fails in my app. I'm not compiling on the fly, just loading the testresults.jasper file and filling it from the db.

 

Any help would be most appreciated! Until then I'll revert back to 0.5.2.

 

 

 

 

By: creonnoir - creonnoir

RE: Errors after moving from 0.5.2 to 0.5.3

2006-01-16 01:57

Never mind... I forgot to change my server.policy file to grant getProtectionDomain and createClassLoader permissions... :)

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...