Jump to content
Changes to the Jaspersoft community edition download ×

iReport Charts and OpenReports Problem


2004 IR Help

Recommended Posts

By: Tim Shouldice - shouldt

iReport Charts and OpenReports Problem

2004-11-08 13:40

I have compiled the latest OpenReports with both jasperreports-0.6.1 and jfreechart-0.9.21 using JDK1.5.

 

It runs standard reports created by iReport-0.4.0 just fine, however when trying to display a report containing a chart I get the following error:

 

Error creating report: Error evaluating expression : image_1 Source text : (java.awt.Image)it.businesslogic.ireport.chart.DefaultChartFactory.drawChart(new String[]{"antialias=true","tooltips=true","legend=true","chartName=Line","plotOrientation=2","foregroundAlpha=0.5","valueLabel=Average CPU","subtitle=","plotBackground=[255,255,255]","showPoints=true","quality=1","height=258","titlePosition=1","chartBackground=[255,255,255]","width=523","serie2=SERIE_VM","serie1=SERIE_Hour","serie0=SERIE_AverageCPU","categoryLabel=Hour of Day","title="}, (it.businesslogic.ireport.IReportScriptlet)$P{REPORT_SCRIPTLET})

 

I manually put the corresponding ReportNameScriptlet.class in the /WEB_INF/classes directory (it complained it couldn't find the class before I manually put the file in the directory).

 

The chart displays just fine under the jasperview in iReports.

 

Any suggestions

 

/Tim

 

 

 

 

By: Tim Shouldice - shouldt

RE: iReport Charts and OpenReports Problem

2004-11-11 12:44

Just to update, I got the problem solved.

 

1. I extracted the whole iReport class library (it.businesslogic.ireport...) and put it in the classes directory. Some of the routines in the chart package call other packages such as the util package.

 

2. The CVS of OpenReports had updated to jasperreports-0.6.1 but hadn't updated the jasper common libraries to jcommon-0.9.6, there are libraries here that get called when servlet functions get invoked.

 

Also, as noted, the scriptlets need to be manually put in the classes directory.

 

With that all done and the OpenReports classes recompiled it all worked.

 

/Tim

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...