Jump to content
Changes to the Jaspersoft community edition download ×

NoClassDefFoundError for Chart Implementation


2005 IR Help

Recommended Posts

By: Bhima_B - bhima_b

NoClassDefFoundError for Chart Implementation

2005-09-01 06:59

Hello,

 

I use iReport for reporting in our web portal. Recently we started doing reports with 'CHART' in it.

I can get it to work on iReport application. but when I copy it to JBOSS server, it is giving the following java.lang.NoClassDefFoundError.

I downloaded the iReport-0.5.0 and copied the iReport.jar & jfreechart-0.9.21.jar from its lib to the Jboss server's lib (/usr/local/java/jboss/server/cti/lib/cti)

The Scriptlet class iReport generated is copied to /usr/local/java/jboss/server/cti/deploy/cti/ebizapp.ear/ProviderPortal.war/WEB-INF/classes, as it was giving NoClassDefFound Errors, when bundled inside our Java jars.

Tried copying the iReport.jar & jfreechart-0.9.21.jar also in the folder along with the Scriptlet class is. Still getting the same error.

StackTrace from JBOSS server is pasted below:-

 

2005-08-29 11:38:07,565 ERROR [sTDERR] java.lang.NoClassDefFoundError: org/jfree/chart/axis/ValueAxis

2005-08-29 11:38:07,566 ERROR [sTDERR] at it.businesslogic.ireport.chart.DefaultChartFactory.drawChart(DefaultChartFactory.java:150)

2005-08-29 11:38:07,566 ERROR [sTDERR] at CHART_totalscans.evaluateOld(CHART_totalscans.java:321)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRCalculator.evaluateOld(JRCalculator.java:342)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRCalculator.evaluate(JRCalculator.java:313)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRFillImage.evaluateImage(JRFillImage.java:350)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRBaseFiller.resolveGroupBoundImages(JRBaseFiller.java:987)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReportContent(JRVerticalFiller.java:224)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:123)

2005-08-29 11:38:07,567 ERROR [sTDERR] at net.sf.jasperreports.engine.fill.JRBaseFiller.fil

 

 

Can anyone help me..

 

Thanks,

Bhima

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...