Jump to content
Changes to the Jaspersoft community edition download ×

Using parameters with Oracle 9i


2005 IR Help

Recommended Posts

By: RobertSchaefer - clayangelo

Using parameters with Oracle 9i

2005-02-07 05:46

Hi,

 

Is there a problem with using parameters when using Oracle 9i?

I carefully set up the parameters using the tutorial and still can't seem to get it to work.

I've set up the parameter in Report Parameters and have placed it in my query "and symbol = $P(symbol)" and it seems to compile fine but when filling the report, I get "Error filling print...

java.sql.SQLException: ORA-00911: invalid character". When I hard code the query, replacing the parameter, the query works fine. Is there a trick to using Oracle in this way?

 

Any help would be greatly appreciated..

 

Robert Schaefer

 

 

 

 

By: RobertSchaefer - clayangelo

RE: Using parameters with Oracle 9i

2005-02-07 06:33

Just figured out what I was doing incorrectly...

 

Don't bother responding to this post..

 

Thank you!!

Link to comment
Share on other sites

  • 2 years later...
  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

It might be to do with quotes? When you do the substitution into the query yourself (i.e. not with a parameter) then did you put quotes around the value? If so then you perhaps need to ensure that the result of the parameter substitution also has quotes around it.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...