Jump to content
Changes to the Jaspersoft community edition download ×

"inconvertible types found" Error compiling


2004 IR Help

Recommended Posts

By: Luciano Zanin - cianoz

"inconvertible types found" Error compiling

2004-03-17 23:53

On iReport 0.2.3.1 i have a report that query a MySQL db. When i try to compile i get this error:

 

Errors compiling E:DocumentiDatabaseEstrazione dati 1 su MySQL.jasper! Warning : Element bottom reaches outside band area : y=15 height=1 band-height=15

C:ProgrammiiReportDati_commesse_Logico1.java:98: inconvertible types found : java.sql.Timestamp required: java.lang.String value = (java.lang.String)(((java.sql.Timestamp)field_consegna.getValue()));

^ C:ProgrammiiReportDati_commesse_Logico1.java:236: inconvertible types found : java.sql.Timestamp required: java.lang.String value = (java.lang.String)(((java.sql.Timestamp)field_consegna.getOldValue()));

^ C:ProgrammiiReportDati_commesse_Logico1.java:374: inconvertible types found : java.sql.Timestamp required: java.lang.String value = (java.lang.String)(((java.sql.Timestamp)field_consegna.getValue()));

^ 3 errors dori.jasper.engine.JRException: Errors were encountered when compiling report expressions class file: See error messages above.

at dori.jasper.engine.design.JRAbstractJavaCompiler.compileReport(JRAbstractJavaCompiler.java:154)

at dori.jasper.engine.design.JRDefaultCompiler.compileReport(JRDefaultCompiler.java:136)

at dori.jasper.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:135)

at dori.jasper.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:123)

at it.businesslogic.ireport.IReportCompiler.run(IReportCompiler.java:148)

at java.lang.Thread.run(Thread.java:534)

 

The query works fine with other non-java tools.

Is it a problem is with the "consegna" field or with some elements positioned outside some band limit ?

The "consegna" field is a DateTime field in the db; in iReport i tried to set it as different type but i always get the same error.

Could someone help me ?

I tried to set

 

 

 

 

By: Luciano Zanin - cianoz

RE: "inconvertible types found" Error compili

2004-03-18 00:03

I reply to myself :-)

I set the field type to "java.sql.Timestamp" and then i SAVED the report and tried to compile: so it works !

I guess i have to save and compile after i make a change like this for having it "registered"... (or not ?)

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...