JasperReports Library - Requirements

JasperReports Requirements

This table contains all the libraries that JasperReports may require, depending on the functionality required by JasperReports's parent application.

 JRE

  • Java Runtime Environment 6.0 or higher

Commons

JRXML

JDBC

  • JDBC 2.0 Driver 

PDF

XLS

Charts

 

Comments

I believe these are out of date? e.g. I have seen mention of POI 3.15 being required in a forum thread.

Its a shame there is no up to date documentation. I find that using ANT v Maven downloads different dependencies as well. Most confusing.

Feedback