Jump to content
  • Bad CodePage jrxml

    Assigned User chicuslavic
    CategoryBug report

    When you open a tested and well running jrxml file, with utf encoding specified in <?xml version="1.0" encoding="UTF-8"?> tag, Jaspersoft Studio open it without no problem.


    When you saves the design, it is saved with OS codepage (I tried under windows XP cp1252) but the xml tag still saying that the xml is encoded with UTF-8.


    Then, when you try to open again the file, if the file has language dependent characters, you can receive an XML SAX Parser Exception telling that the xml file is not UTF-8 encoded.


    You can open it again if you manually changes the encoding property of the xml tag to encoding="windows-1252", but again, when you saves your design, this is changed to utf-8.

    Attachments: Prova.jrxml

    User Feedback

    Recommended Comments

    I'm sorry.


    Many thanks for your attention. But, are you sure you have released the fix on 0.2.2 version? I have tried it, but I have exactly the same problem.


    If you see the xml code, you can see this:

    <?xml version="1.0" encoding="UTF-8"?>


    "Prová "+$F{prova1}



    In UTF encoding, á character should never appear.


    Kind regards,

    Link to comment
    Share on other sites

    I'm sorry to tell you, but this bug persits.


    If you edit directly the xml file, the special language caracters aren't well saved.


    I tried with Windows-1252 and with utf-8 codepages.


    Kind regards,

    Link to comment
    Share on other sites

    Seems only to happen once you've used the source editor.


    Picks default locale: saves the files as latin1 without changing the <?xml version="1.0" encoding="UTF-8"?> line on my system.


    Jaspersoft Studio-1.0.7

    Windows 7 Professional, Service Pack 1, 64-bit

    Link to comment
    Share on other sites

    Problem still exists!!! (long long time)


    The Designer writes it nice but the source view saves all äöü § into other characters.


    is there a workaround?


    Jaspersoft Studio-1.3.2

    Windows 7 Professional, 64-bit

    Link to comment
    Share on other sites



    it's possible to make a screencast, with all the steps to reproduce the problem?


    because I tested on winXP and win7 and I can't reproduce it, maybe you do it in a different way


    thank you

    Link to comment
    Share on other sites

    I have this problem when I made changes in the source-view. Entering ÖÄÜ in the Designer is no problem. When I go to the source-view and change something (no matter what), ÖÄÜ is changed to ���.
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...