Jump to content
  • JSS 5.6.1 beta does not allow fields/paramaters to be dropped in the report

    Assigned User Massimo Rabbi
    CategoryBug report
    StatusFeedback Requested



    In a list, we can no longer drag fields or paramaters into the design view. Creating a field manually and typing the $F/P{...} manually does work.


    The error we get: "You drop an object from a subdataset into a report, this is not possible".


    The error is wrong, I am in the subreport's context, inside the list.


    Kind regards,

    Maarten @ Yesplan


    User Feedback

    Recommended Comments

    Changed Status from New to Feedback Requested

    Changed Assigned User from @User_306070 to @anonymous

    Hi can you attach the report that is causing problems? Or register a screencast?I tried adding a list with Dataset1. And in Design mode I can drag and drop fields from the dataset.Not sure I understood how the subreport is involved. Regards,Massimo.
    Link to comment
    Share on other sites

    My apologies, bad choice of words. I meant in the context of the subdataset of the list, not subreport.


    I have it in all lists.


    Mac, Java 7, JSS 5.6.1.SNAPSHOT.beta.v201407010859

    Link to comment
    Share on other sites

    Hi Marteen,

    I just tried. I got the same error when trying to drop the field upon an existing textfield.

    For sure this message is not correct and we will fix it. Anyhow if you create space for the drop, you should not have problems.




    Link to comment
    Share on other sites

    I also got the same error with Jaspersoft Studio. If I drag the fields to main report fields, then the drag/drop to Detail band works. But I'm not sure why I have to do it and also why doesn't the main fields in report do not get the fields selected from Javabean dataset using Collection data source.
    Link to comment
    Share on other sites

    Changed Resolution from Fixed to Open

    Changed Status from Resolved to Feedback Requested

    Hi, Do you know if this issue has been fixed? I am still experiencing the same issue. Thanks.
    Link to comment
    Share on other sites

  • Create New...