Jump to content
  • Unauthorized 401 error connecting JasperStudio to JasperServer 5.2.0

    Assigned User chicuslavic
    CategoryBug report



    today I started with Jaspersoft Server 5.2.0 CP and JasperSoft Studio 5.2.0 (Community Edition) both 64 Bit on a Windows 7 64 Bit pro.

    Java is 64 bit as well. I installed JasperStudio 64 Bit and JasperServer on 64 Bit on the same machine.

    I started JasperStudio and wanted to create a Server Connection but this failed.

    I got an Unauthorized 401 error.


    Username and password is entered correctly, I tried several times. I used the standard credentials jasperadmin.


    Here are the Details:




    faultCode: {http://xml.apache.org/axis/}HTTP


    faultString: (401)Unauthorized




    {}:return code: 401

    <html><head><title>Apache Tomcat/6.0.26 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 401 - Bad credentials</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Bad credentials</u></p><p><b>description</b> <u>This request requires HTTP authentication (Bad credentials).</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.26</h3></body></html>




    at org.apache.axis.transport.http.CommonsHTTPSender.invoke(CommonsHTTPSender.java:221)

    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)

    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)

    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)

    at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)

    at org.apache.axis.client.Call.invokeEngine(Call.java:2784)

    at org.apache.axis.client.Call.invoke(Call.java:2767)

    at org.apache.axis.client.Call.invoke(Call.java:2443)

    at org.apache.axis.client.Call.invoke(Call.java:2366)

    at org.apache.axis.client.Call.invoke(Call.java:1812)

    at com.jaspersoft.ireport.jasperserver.ws.RepositorySoapBindingStub.list(RepositorySoapBindingStub.java:339)

    at com.jaspersoft.ireport.jasperserver.ws.WSClient.getVersion(WSClient.java:152)

    at com.jaspersoft.studio.server.protocol.soap.SoapConnection.getServerInfo(SoapConnection.java:29)

    at com.jaspersoft.studio.server.protocol.soap.SoapConnection.connect(SoapConnection.java:39)

    at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:25)

    at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:75)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:106)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:100)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:80)

    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)





    User Feedback

    Recommended Comments

    Changed Status from New to Feedback Requested

    Changed Assigned User from - to @User_306070

    Hi,it seems an authentication problem. Supposing you are using the correct credentials, it could be something wrong with the password storing.We are using the Eclipse Secure Storage mechanism in order to save the password used for server connections and some data adapters.Could you please confirm that if you open the "Server profile wizard" and 1) re-enter username and password 2) hit the test button, the connection attempt works fine?If yes, please try to re-save credentials, hitting the "Finish" button.Please let me know.Best regards,Massimo.
    Link to comment
    Share on other sites

    Changed Assigned User from @User_306070 to @anonymous

    Hi Massimo,thanks for trying to help me.As I wrote in my 1st post:>Username and password is entered correctly, I tried several times. I used the standard credentials jasperadmin.Username and password are correct. I did it again as you suggested with default username jasperadmin and password jasperadmin.But it still fails on hitting 'Test connection' with same error.I also changed the password for user jasperadmin inside the web interface of jasperserver.With the new password I can login into web-interface of jasperserver without problem.But inside JasperSoft 'Server Profile Wizard' I have still same problem :-(Still need help, thanks!
    Link to comment
    Share on other sites


    so given your answer I would exclude a problem possibly related to the Eclipse Secure Storage.

    I gave a look at your studio preferences file. It appears you are using also the field "Organization". Could you please try with this information blank and the default jasperadmin/jasperadmin credentials (or different password if you changed it)? Probably the organization information is not handled correctly or is wrong.


    Best regards,


    Link to comment
    Share on other sites

    Hi Massimo,


    I tried what you suggested and yes, it solved the problem.

    I kept the field 'Organization' empty and now it works!


    Does this mean I never can use the field 'Organization'? Or do I have to enter it in jasperserver as well somewhere?


    Link to comment
    Share on other sites

    Changed Resolution from Open to No Change Required

    Changed Status from Feedback Requested to Closed

    Changed Assigned User from @anonymous to @mrabbi

    Hi Timon.First of all, which version of JasperReports Server are you using? Anyhow the field "Organization" can be used, but it is of course something that is referred to the JRS configuration.For example as far as I know by default there should be an "organization_1" entry to which for example even the jasperadmin user is associated.Therefore if you put "organization_1" in the Server Profile wizard field, it should work. It works for me, just tried.Anyhow, in order to configure "Organizations" (see here: http://help.jaspersoft.com/js-help-v5-en//Default.htm#js-help/Managing_Organizations.htm) you should have a specific license for the commercial version of JRS. Personally, I'm not the correct person in order to reply regarding this topic. Just in case open a ticket in the JRS tracker or better for different versions information, please refer to this page: https://www.jaspersoft.com/editions. As you can see on the bottom there is the button "Chat with Jaspersoft Sales". I think you can use that one for having more info.Hope this solves, your doubts.I will close the bug.Best regards,Massimo.
    Link to comment
    Share on other sites

    baalaa13 is correct. You can't have any special characters in your password if you want to connect to JasperReports Server from Jaspersoft Studio, it can only be letters and numbers. I'm not sure how baalaa13 figured that out but thank-you!
    Link to comment
    Share on other sites

    Changed Resolution from No Change Required to Fixed

    Changed Status from Closed to Resolved

    Changed Assigned User from - to @chicuslavic

    I found the bug, it's about special chars. I fixed it, you could try it on the next release, I hope soon.
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...