Jump to content
  • DB2 JDBC (jt400.jar) not registered in DataAdapter Wizard

    Assigned User anonymous
    CategoryBug report
    ResolutionNo Change Required

    I just installed the Jasper Studio plugin to my IBM RDi (Eclipse). The installation went without a problem and the plugin appears to be coexisting with the version of Eclipse and working. But as soon as I tried out a sample report, I ran into problem with my data source. In DataAdapter Wizard, I specified the location of my jt400.jar in the add to classpath tab but the wizard did not register when clicking on TEST button.

    How to make jt400.jar (IBM iSeries JDBC driver) appear in the DataAdapter Wizard?

    Attachments: issueDetails.zip

    User Feedback

    Recommended Comments

    Changed Assigned User from - to @User_306070

    Hi,glad to hear you were able to install JSS in IBM RDi without any compatibility problems.Regarding your problem, could you please attach the error log or at least the stacktrace produced, when hitting the Test button? As far as I understand, you are saying that the jt400.jar is not being correctly considered? Is it the entry saved once you click finish on the wizard and reopen it?Just for now maybe try as quick solution to add the driver(s) in the project classpath (Java Build-Path Property page).Best regards,Massimo.
    Link to comment
    Share on other sites

    I've downloaded jt400.jar from http://jt400.sourceforge.net/


    added the jar to Data Adapters classpath, used driver class com.ibm.as400.access.AS400JDBCDriver

    and url jdbc:as400://mySystem;name1=value1;name2=value2;


    on pushing Test button, I get a Swing Authentication dialog, filled something for the user, password, and get a connection error, I don't have a DB2


    but this means, driver is loading and connection should be created if I'll have DB2 credentials


    I attach, the Data Adapter to my comment


    can you please export the DataAdapter to a file, and send me to look at it? also tell me more, what DB2 version you have, what is the client configuration, what is your driver classname, what url you are trying, give me the error stacktrace

    maybe you try to use something native, in this case you have to add some more jars



    Link to comment
    Share on other sites

    Changed Resolution from Open to No Change Required

    Changed Status from Feedback Requested to Closed

    Closing the bug. No more feedback received. Currently the PRO version of JSS supports DB2 correctly.
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...