Jump to content
  • 401 (Unauthorized) after Jaspersoft Studio update

    CategoryBug report

    Jaspersoft Studio has performed some automatic updates this morning and I can no longer connect to any of the servers. There were no configuration or authentication changes on our end. I am able to log into the servers online.


    For example, we have this server:

    un: jasperadmin

    Product Version: 7.5.0

    Build: 20191206_1440


    I am using Jaspersoft Studio v6.15.0 on an iMac / macOS Catalina v10.15.7


    A screenshot from the Server Profile Wizard in JasperSoft Studio, showing connection params, is attached (it hasn't changed from immediately prior to the update).


    When I click on "Test Connection", I get the following error:


    org.apache.http.client.HttpResponseException: status code: 401, reason phrase: 401

    at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:67)

    at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.doConnectLogin(RestV2ConnectionJersey.java:328)

    at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.doConnect(RestV2ConnectionJersey.java:243)

    at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:223)

    at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:118)

    at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:92)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:94)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:89)

    at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:68)

    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)


    What could I check/test to get the connection restored? I re-verified that user name and password haven't changed, that I can log in with these credentials online, and that this user has the following roles assigned: ROLE_ADMINISTRATOR and ROLE_USER.


    Any help is appreciated!








    User Feedback

    Recommended Comments

    I tried re-installing v6.15.0 and then 6.14.0, but neither would work. Had to go back to 6.13.0 -- that's the last version to work / be able to connect to Jaspersoft Server 7.5.0
    Link to comment
    Share on other sites

    Did you upgrade from 6.14.0 or 6.13.0? It's not clear which was your original version.

    Moveover did you upgrade the RCP version (standalone) or an Eclipse installation with the plugin?




    Link to comment
    Share on other sites

    Changed Assigned User from - to @chicuslavic

    Could you verify if you have spaces in organisation field?Could you look what is sent to the server and back?I verified with all the servers I have on hand connection works fine for me.
    Link to comment
    Share on other sites

    Upgraded from 6.13.0 because 6.14.0 does not work either. Reproducible by multiple people at the company -- 6.14.0 and 6.15.0 simply can't connect to the server, everyone had to roll back to 6.13.0. There are no spaces in the organization field.


    Here's what I've tried: I completely uninstalled v6.15.0 and then:

    - reinstalled v6.14.0 from this package: https://community.jaspersoft.com/project/jaspersoft-studio/releases (Specifically https://community.jaspersoft.com/project/jaspersoft-studio/releases?release_id=1164511&download=https%3A//sourceforge.net/projects/jasperstudio/files/JaspersoftStudio-6.14.0/TIB_js-studiocomm_6.14.0_macosx_x86_64.dmg/download)

    - then deleted v6.14.0 and reinstalled v6.15.0 again (https://community.jaspersoft.com/project/jaspersoft-studio/releases?release_id=1172456&download=https%3A//sourceforge.net/projects/jasperstudio/files/JaspersoftStudio-6.15.0/TIB_js-studiocomm_6.15.0_macosx_x86_64.dmg/download)

    - then, when that did not work, deleted 6.15.0 and reinstalled 6.13.0 from the same page, which works.


    How can I check what is sent to the server and back? If you could let me know, I will reinstall 6.15.0 and compare what's being sent for 6.13.0 v 6.15.0

    Link to comment
    Share on other sites

    @chicuslavic -- please see the question above. How can I activate logs or send the conversation between client and server? Could you please point me to an article that describes how to do this, and I will send you logs and client-server communications. Thank you!
    Link to comment
    Share on other sites

    I found that if the user password has any special character (like '@', '#', etc), this error will occur. Temporary workaround is change the user password to something that does not have special character. But, this is insecure.
    Link to comment
    Share on other sites

    Changed Resolution from Reopened to Fixed

    Changed Status from Feedback Requested to Resolved

    Try to download the new 6.16.0 and re-test. The bug was fixed after the 6.15.0. You can see that the bug is clearly mentioning that.Regards,Massimo.
    Link to comment
    Share on other sites

    Dumbest bug ever.. had to transfer my reports manually to the server via the web interface and do most of the designing work ON the server just to be able to quickly see my changes LOL. Even cancelled my plan to buy the paid version. Well, at least its solved now. Countless thanks to whoever made the fix
    Link to comment
    Share on other sites

  • Create New...