Jump to content
  • JasperStudio Update failed because wrong path of binary

    Assigned User Massimo Rabbi
    CategoryBug report
    Component: 22351
    ResolutionUnable to Reproduce

    The update of the plugins failed because the last step (chmod of the start script) failed. The command is:

    chmod +x /Applications/JasperStudio_6.app/Contents/Eclipse/../MacOS//Jaspersoft Studio

    Then response is:

    chmod: Studio: No such file or directory


    The probleme here are the spaces in the path. The whole path in this command must be enclosed in "


    The correct command have to be:

    chmod +x "/Applications/JasperStudio_6.app/Contents/Eclipse/../MacOS//Jaspersoft Studio"


    or even better:

    chmod +x "/Applications/JasperStudio_6.app/Contents/MacOS/Jaspersoft Studio"


    User Feedback

    Recommended Comments

    The installation of the plugin update runs until a point in in which the installation routine tries to change the file system rights of updated script. I guess this will only happen in UNIX environments. Windows does not need such a command.
    Link to comment
    Share on other sites

    I'm not actually understanding where you see this command being executed / run.

    Can you please register a screencast of the problem?


    Moreover from the extract you posted it seems that you are trying to upgrade the RCP application and not the plugin one. Starting from which version?

    I personally tried to upgrade from the 6.10.0 to latest 6.12.2 (MacOS 10.15.3) using the internal update mechanism and it worked fine. The only thing I noticed is that the automatic restart seems to not being "considered". But when I double clicked on the application it started correctly the updated version.


    Besides this "restart now" not being considered, something we might want to check, I don't get where you found out this chmod message. I don't recall we do something on purpose for it.


    Please register a screencast and details on the versions of JSS + OS.





    Link to comment
    Share on other sites

    Changed Resolution from Reopened to Unable to Reproduce

    Changed Status from New to Closed

    Hi, there is nothing "hard to understand". As mentioned in my message I tried to upgrade from a version 6.10 to a 6.12.2. And those are the results.Moreover I just tried with an existing 6.13.0 and I upgraded to a 6.16.0, always on a Mac OS X 10.15.3 and it worked the same.I asked about those stuff because for example in your initial message it was not clear from which version you were upgrading from. And only now I see from the screenshot your original installation was a 6.4.3. But maybe you upgraded to newer versions already in the past, I can only assume that. The reasons why something can not be reproduced can be multiples, like for example the workspace, OS version configuration or like probably in this case the upgrade story. For example that error message is the first time I see it.That said since it's something that seems not easy to debug I would recommend to move to the most recent version directly.Regards,Massimo.
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...