[#9536] - Hyperlink which link to another report not working

Category:
Bug report
Priority:
Immediate
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

JasperServer version: 6.2.1
JasperMobile version: 2.5.1.004
Phone: Asus ZenFone 3 ZE552KL
Android version: 7.0 Nougat
ROM: Original ASUS ROM (not rooted)

On JasperServer, I have a report which has a hyperlink to another report. The hyperlink works well in web browsers, but not working in JasperMobile for Android. On JasperMobile app, when I tap the hyperlink, nothing happened.

I had attached two sample reports here. The report "test_report.jrxml" has a field "Click me to run another report". This field was linked to another report, "test_sub_report.jrxml" through hyperlink. Both reports are placed in the same directory in JasperServer. When using web browser to view the report, the hyperlink work perfectly. But, when using JasperMobile app, the hyperlink not working at all.

AttachmentSize
Binary Data test_report.jrxml1.83 KB
Binary Data test_sub_report.jrxml1.56 KB
v6.2.1
cshong87's picture
Joined: Aug 22 2013 - 11:12pm
Last seen: 2 months 1 week ago

5 Comments:

#1
  • Reproducibility:N/A» Always
#2
  • Severity:Minor» Critical
#3

Our business users mainly travel all the time, and they want to access the jasper BI reports in mobile. This project mainly is a migration project from OBIEE dashboard and recently moved important dashboards to jasperserver and its working fine in Desktop. The only stop point for us is this issue with the mobile.

#4

Our business users mainly travel all the time, and they want to access the jasper BI reports in mobile. This project mainly is a migration project from OBIEE dashboard and recently moved important dashboards to jasperserver and its working fine in Desktop. The only stop point for us is this issue with the mobile.

#5
  • Priority:Normal» Immediate
  • Severity:Critical» Block
Feedback