JDBC Connection to SQL Server Not Working

Hi, 

I have been struggling to connect jasper reports to my SQL Server 2008. I've tried a few different drivers, and it appears I'm able to connect, but it always complains about my user ID, or security. I know I can connect with these credentials as I use SSMS all the time with them. I've tried doing a few things, like adding our domain to the server in the connection string, or prefixing my user id with domain\username. 

I made a video: youtu.be/nPfJXYo6q9U

This video shows the strange behaviour while I try to create a data source, then a report. You'll see at 1:12 the new data source connection is successful. But when I try to create a new report and use that data source, it then complains that it's not set up to use integrated security... then why did it connect in the first place? I have added the sqljdbc_auth.dll file to every JRE and JDK BIN and LIB folder on my computer to be safe. I started with the 64 bit auth dll, since that's the version of Java I am running, and then just for kicks, I tried the 32 bit auth dll. Neither worked. 

I have no idea what else I can do... but I'm very frustrated that I can't connect to SQL Server. I've been able to connect to Oracle, and Sybase without any problems, or special configurations. Just point to the JDBC driver jar file, and create your connection string. Why is SQL Server so different for me?

david.tessier@live.com's picture
Joined: Feb 4 2016 - 5:24am
Last seen: 1 year 6 months ago

0 Answers:

No answers yet
Feedback