How to set context param in *.bat file for jasperELT?

1

In my *.bat file the content is like below:

java -Xms256M -Xmx1024M -cp ../lib/systemRoutines.jar;../lib/userRoutines.jar;.;dailyreportalljob_0_1.jar;dailycnt_0_1.jar;dailynotpass_0_1.jar;../lib/advancedPersistentLookupLib-1.0.jar;../lib/commons-collections-3.2.jar;../lib/dom4j-1.6.1.jar;../lib/jboss-serialization.jar;../lib/log4j-1.2.15.jar;../lib/mysql-connector-java-5.1.30-bin.jar;../lib/trove.jar; dailyreport.dailyreportalljob_0_1.DailyReportAllJob --context=Default --context_param search_date=20151027 %* 

In default config search_date is 20150101, and I have used "--context_param search_date=20151027" to set search_date with 20151027.

The result is that search_date still got default config value.

Can you help me to give me any solutions? Thanks a lot.

fengjianquan_1's picture
Joined: Oct 8 2015 - 7:18pm
Last seen: 4 years 2 weeks ago

This is soluted. Thanks

fengjianquan_1 - 4 years 3 weeks ago

Hi Ted,

can you share the solution you found by yourself?

Thanks!

kkumlien - 4 years 2 weeks ago

The "--context_param search_date=20151027" is correct.

Just my etl program need to run all job, so used [tRunJob] but not selected [Transmit whole context].

fengjianquan_1 - 4 years 2 weeks ago
show 1 more...

Thanks Ted! I added your solution below as an answer and upvoted your question ; )

kkumlien - 4 years 2 weeks ago

1 Answer:

1

Based on the comment above from Ted, he resolved his own question by enabling the flag (selecting the checkbox) "Transmit whole context" on the parent job, which is documented here: https://help.talend.com/display/TalendOpenStudioComponentsReferenceGuide...

kkumlien's picture
2856
Joined: Jan 22 2015 - 4:36am
Last seen: 1 day 6 hours ago
Feedback