Rendering report with N pages - Ignore Pagination

0
Hello, I have a table report with multiple pages and I'm rendering in a #container. But only show the first page.
I would like that this report doesn't break the table and show me all registers.
 
What I have to do?
 
Thank you.
matheusluz39's picture
Joined: Aug 11 2015 - 7:00am
Last seen: 3 years 1 week ago

hi.. can you please explain how you solved the issue?? I am also getting the same issue, rendering only the first page, 

please help me .

anoopllknpy - 3 years 8 months ago

3 Answers:

0
I just found the option Ignore Pagination.
It's possible change this option dinamically?
 
When I'll render the report set true and when I'll export to pdf set false.
 
matheusluz39's picture
Joined: Aug 11 2015 - 7:00am
Last seen: 3 years 1 week ago
0
hozawa's picture
45109
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 month 1 week ago
0

I am running into the same issue - but only on export. I am using the Visualize.js library with AngularJS on the front end. Report renders fine - no breaks, but on export, the XLS renders in multiple segments. Pagination is set to false on the JasperServer. I tried adding the option: "pagination: false" to the export call, but it seems to be completely ignoring the parameter when it makes the actual REST call. My requested export format is there, and if I specify number of pages I can see that too, but pagination: false is never there.

Is this a known bug with the Visualize.js library?

jclarke_1's picture
Joined: Feb 9 2015 - 9:09am
Last seen: 2 years 5 months ago
Feedback