Problem in jasperserver war installation for community version

0

Hi,

I was a happy japserserver user with the bundled tomcat, postgresql. But now I am going nuts.

I am trying to install japserserver with existing tomcat6 and mysql server on ubuntu. So, I am using the war file for installation.

Specifications of my system  : tomcat6, java version "1.8.0_60" , mysql5.5 (all installed)

The bulid failed during the execution of js-install-ce.sh

The exception I get in the log created is:

[java] Started to load resources
     [java] Resource name: applicationContext.xml
     [java] Resource name: applicationContext-cascade.xml
     [java] Resource name: applicationContext-data-snapshots.xml
     [java] Resource name: applicationContext-events-logging.xml
     [java] Resource name: applicationContext-export-config.xml
     [java] Resource name: applicationContext-export-import.xml
     [java] Resource name: applicationContext-logging.xml
     [java] Resource name: applicationContext-olap-connection.xml
     [java] Resource name: applicationContext-propertySettings.xml
     [java] Resource name: applicationContext-report-scheduling.xml
     [java] Resource name: applicationContext-search.xml
     [java] Resource name: applicationContext-security.xml
     [java] Resource name: applicationContext-themes.xml
     [java] Resource name: applicationContext-virtual-data-source.xml
     [java] org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'actionModelService' defined in file [<path to>/jasperreports-server-cp-6.0.1-bin/buildomatic/conf_source/ieCe/applicationContext.xml]: Invocation of init method failed; nested exception is java.lang.ExceptionInInitializerError
     [java]  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1512)
     [java]  at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:521)

Then I started to run commnads as mentioned here, http://jasperserver.sourceforge.net/docs/3-7-0/JasperServer-CE-Install-Guide.pdf, inspite of running that install script.

but got the same error after executing : js-ant import-minimal-ce

Then I checked my database where I found that the databases jasperserver, foodmart, sugarcrm were created. All tables created. But no data was there in tables of jasperserver.

Then I tried the things mentioned here, http://community.jaspersoft.com/documentation/jasperreports-server-community-build-guide/v56/create-and-load-sample-data

js-ant re-int-js-db-pro : successful

js-ant run-production-data-pro : BUILD FAILED

/<path to>/jasperreports-server-cp-6.0.1-bin/buildomatic/bin/dev.xml:642: The following error occurred while executing this line:

/<path to>/jasperreports-server-cp-6.0.1-bin/buildomatic/bin/dev.xml:94: "maven" or "maven.home" property needs to be set

I am stuck with the installation for 4 days now. I am all clueless. Please help.

jasperServerUser's picture
Joined: Sep 3 2015 - 11:56pm
Last seen: 3 years 10 months ago

1 Answer:

1

JasperReports Server 6.0.1 doesn't  support JDK1.8. You'll have to use Oracle JDK1.7 or Oracle JDK1.6.

hozawa's picture
47137
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 months 2 weeks ago
Feedback