Will Ireports 5.6 run on Windows 10?

2

Will Ireports 5.6 run on Windows 10?

donna.ragsdale's picture
Joined: Feb 25 2015 - 6:29am
Last seen: 3 years 7 months ago

si

jakub.monikowski - 3 years 7 months ago

I have Java 8 latest build u102, iReport 5.6 on Windows 10.

The start-up fails while: "Loading cached objects" ... no messages, even if I run from the command line.

I am looking for a log file or command line option that will let me troubleshoot this problem.  Something like --logfile report.log ??

Since the last thing I see is loading from cache, I tried to point it to a specific directory, as is done with netbeans IDE.  I don' think that option is supported.  Seems to be ignoring it.

...\ireport.exe  --jdkhome=c:\java\u102\x64  --userdir  d:\ireport\v05.06\user --cachedir d:\ireport\v05.06\cache

Can someone tel lme where logging goes? And/or how to turn logging on either on command line or from the conf file?

many thanks, w.

william.full.moon - 2 years 7 months ago

ONLY works with Java 7 it seems -- see comment below from mariocp

Also the command line option has no effect, must use the .conf file as stated.  A collegue has it working on windows 8 using java 7.

 

w.

william.full.moon - 2 years 7 months ago

4 Answers:

0

Try it. If it does not, it won't. iReport development has already terminated. Support is going to be terminated at the end of this year. Switch over to Jaspersoft Studio.

hozawa's picture
39133
Joined: Apr 24 2010 - 4:31pm
Last seen: 17 hours 17 min ago
10

Yes, it does. I guest, the main thing is about Java 8.

 

I set jdkhome="C:\Program Files\Java\jdk1.7.0_80"

in the C:\Program Files (x86)\Jaspersoft\iReport-5.6.0\etc\ireport.conf

 

It does not work with jdk1.8.0_60, maybe it works with an older version of java.

 

Product Version: Jaspersoft iReport Designer 5.6.0

Java: 1.7.0_80; Java HotSpot(TM) 64-Bit Server VM 24.80-b11

System: Windows 8.1 version 6.3 running on amd64; Cp1252; en_US (ireport)

Userdir: C:\Users\mcp\.ireport\5.6.0

I'm not sure why in About says Windows 8.1, I'm not using compatibility mode.

mariocp's picture
110
Joined: Sep 30 2015 - 10:59am
Last seen: 3 years 5 months ago
0

Thanks mariocp it worked for me in Windows 10

gary_9's picture
10
Joined: Nov 24 2014 - 10:01am
Last seen: 2 years 8 months ago
0

Sorry for the deduct...hope I fixed it.

gary_9's picture
10
Joined: Nov 24 2014 - 10:01am
Last seen: 2 years 8 months ago
Feedback
randomness