Working on WebSphere with Jasper Soft.Facing this issue..

0
I deployed the JasperServer WAR file using Websphere 8.5.5.The deployment is successful and in the logs i can see this error..
 
0000004a webapp        E com.ibm.ws.webcontainer.webapp.WebApp notifyServletContextCreated SRVE0283E: Exception caught while initializing context: {0}
                                 org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'virtualDataSourceServiceFactory' defined in ServletContext resource [/WEB-INF/applicationContext.xml]: Cannot resolve reference to bean 'virtualDataSourceHandler' while setting bean property 'virtualDataSourceHandler'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'virtualDataSourceHandler' defined in ServletContext resource [/WEB-INF/applicationContext-virtual-data-source.xml]: Cannot resolve reference to bean 'teiidVirtualQueryService' while setting bean property 'virtualDataSourceQueryService'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'teiidVirtualQueryService' defined in ServletContext resource [/WEB-INF/applicationContext-virtual-data-source.xml]: Invocation of init method failed; nested exception is java.lang.ExceptionInInitializerError
at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:329)
krishna.dp9's picture
Joined: Jul 14 2015 - 8:23am
Last seen: 4 years 4 months ago

3 Answers:

-1

Which version of JasperReports Server did you use? I think JasperReports Server 6.1.0 only supported WebSphere 8.5.

hozawa's picture
54360
Joined: Apr 24 2010 - 4:31pm
Last seen: 6 months 1 day ago
0

@hozawa

Thanks for your quick reply

jasperreports-server-5.6.1

krishna.dp9's picture
Joined: Jul 14 2015 - 8:23am
Last seen: 4 years 4 months ago
0

Sorry. 5.6.1 doesn't support WebSphere 8.5.5.

As a matter of fact, I had numerious errors trying to install 5.6.1 on WebSphere 8.0.

The error you're getting just signifies your JasperReports Server repository is invalid. You need to be using IBM JDK6.

hozawa's picture
54360
Joined: Apr 24 2010 - 4:31pm
Last seen: 6 months 1 day ago
Feedback