create reports with JasperReport and odoo 8


I use odoo 8 (formerly OpenERP), JasperReport from and iReport 5.2.0. I try to make a report and find errors like this:

Traceback (most recent call last):
  File "/opt/openerp/server/openerp/", line 296, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server/openerp/service/", line 660, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/openerp/service/", line 766, in exp_report_get
    return self._check_report(report_id)
  File "/opt/openerp/server/openerp/service/", line 744, in _check_report
    netsvc.abort_response(exc, exc.message, 'warning', exc.traceback)
  File "/opt/openerp/server/openerp/", line 71, in abort_response
    raise openerp.osv.osv.except_osv(description, details)
except_osv: (u'Report Error', u'Failed to invoke method execute in class com.nantic.jasperreports.JasperServer: null')

  1. I've tried to update the java libraries in JasperReport module using file. With the command line:
  2. I've tried to install java openjdk-7-jdk and openjdk-7-jre in ubuntu server

But the error was always appear, if anyone could help me? Anyone know the solution?

baim's picture
Joined: Jan 18 2012 - 8:22pm
Last seen: 1 year 2 months ago

 Hello could you  integrated odoo with jasper report, or is a myth?  thanks

distrilandrossi - 3 years 9 months ago

1 Answer:

sehrishnaz47's picture
Joined: May 16 2018 - 4:08am
Last seen: 1 month 4 days ago