File Loading Issue - JasperServer

0

Greetings jasper community,

We've been struggling to load any object (jrxml, image, etc) to JasperServer. The errors that we have are the following:

  • Trying to upload a default vanilla report via "Reports (Right Click) > Add Resource > JasperReport" we have the error "Locate Local File" after browsing the valid jxrml file in the local computer and press "Submit"

  • Trying to upload any file (jxrml, image, etc) via "Reports (Right Click) > Add Resource > File > Image" we always have the error "There must be a title":

So far we already did the following steps:

  • Reinstalled the server;
  • "Chmoded" all the installation DIR and /tmp folder;
  • Re-imported a fresh "jasperadmin" schema seed into oracle;
  • Imported working config files (security.properties, ESAPI.properties, et) from a working server;
  • Compared "jasperadmin" number of tables between the working environment and the one with this error - No differences found;
  • Compared "jasperadmin" jirole/jiuser and jiobjectpermission tables between the working environment and the one with this error - No differences found;
  • Compared files and their content at unix level between the working environment and the one with this error - Same content / number of files (some small differences regarding tmp directories and instance id's);
  • Confirmed that security-config.properties security is set to "True" (It seems that there was a bug regarding security in the previous jasper version);
  • Googled hard!

Server details:

  • OS: AIX Unix
  • DB: Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production
  • Java: IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr15-20131016_170922

Can you help us? This error persist for some time now and so far we were not able to find out the reason why. If you need more details please let us know.

Thanks,

joaosilvapimentel's picture
Joined: Sep 8 2014 - 1:35am
Last seen: 3 years 1 week ago

I have had some problem uploading files with IE. Was able to upload with Firefox.

Also, check the jasperreports log to see if there is any error.

hozawa - 4 years 4 months ago

Good Evening hozawa,

Thanks for your input.

We have the same errors while using another browsers (the output error is the same).

The logs (including ../jasperserver-pro.war/WEB-INF/logs/jasperserver.log) don't log this issue, even in DEBUG mode. We've stopped the app, changed the logging level to DEBUG, restarted it, everything was logged (connecting, etc) but the actions themselves. At the timestamp of the errors nothing was logged.

We are really running out of ideas.

Regards,

 

 

joaosilvapimentel - 4 years 4 months ago

Which version of JasperReports Server are you using?

hozawa - 4 years 4 months ago
show 3 more...

Extracted directly from the About:

"

Product Edition: Enterprise

Product Version: 4.7.0

Build: 20120629_1126

License Type: Commercial

Expiration: 2015-10-30 00:59

"

We know that the previous jasper version had an issue with security level in the configs (if set to false no files were loaded).

In our tests we've tried to load the files with the security =true and =false. None of them worked.

 

 

joaosilvapimentel - 4 years 4 months ago

Did you find a solution?

I'm having the exact same problem as you.

simon_14 - 3 years 5 months ago

Hello Simon_14,

Sadly no, I didn't.

Regards,

joaosilvapimentel - 3 years 1 week ago

0 Answers:

No answers yet
Feedback