JS Studio chart subreport tutorial fails with 'Category series name is null' error

2

I am new to Jaspersoft.  I downloaded and installed Jaspersoft Studio 6.0.3 onto my MacPro and launched the 'Designing a Report with Jaspersoft Studio' wiki page.  I successfully completed the tutorial for creating a simple report and so I proceeded to the 'Creating Charts and Subreports with Jaspersoft Studio' tutorial.

I followed the instructions carefully but when I went to preview the chart I received the error message 'Category series name is null'.

As I was following the tutorial instructions carefully, I was surprised to get such an error.  I searched the internet using Google to see whether anyone else had experienced this problem.  The error message does seem to come up in a number of circumstances but nobody else seems to have experienced it while trying to do the tutorial and so the answers I have found have not been helpful.

The only information I have been able to glean from the web is:

  • I must provide three things for the bar graph to work: a Category, a Series and actual data
  • I must not have any null values in any of those three things

The tutorial lacks detail around the section that talks about setting up the chart and next to the Category field the note actually states "For the example we don't need a category, so here you can insert a void string".  This seems to contradict what I have since found online, but when I try to add another 'category' column to my dataset and use that column for the chart 'Category' field, I still get the same error.

The tutorial SQL query for the chart subreport does not return any null values, so I am at a loss as to how to make this tutorial work.

I would really like the Jaspersoft product to work as I am searching for a replacement for our existing Oracle BI software and Jaspersoft has great potential.  I would just like to be able to prove to my employer that it can do what we need and being able to complete the basic tutorial examples would go a long way to achieving that goal.

plewis7's picture
11
Joined: Mar 26 2012 - 4:06pm
Last seen: 2 years 9 months ago

Hi I am in the position as you following the tutorials and have not found an answer.

obrienw - 4 years 3 weeks ago

I too am having this problem on windows 7. I have tried several tutorials and they all fail with some soft of  "null" error. Any help would be greatly appreciated!!!

I spent a day on this and from what I can tell, none of the charts work with windows 7 and 6.0.3. I get null and other errors no matter what I do. Maybe I will try an older version of jaspersoft!

 

UPDATE: I just rolled back to 6.0.1 and got a chart to actually work! Willkeep trying other stuff.

alleycat142004 - 4 years 2 weeks ago

I am now able to use charts by rolling back to 6.0.1.

alleycat142004 - 4 years 2 weeks ago

0 Answers:

No answers yet
Feedback