Migrating to Jaspersoft Studio

0

Hi,

I'm migrating all of my report (more or less 40 reports) designed with iReport 5 to Jaspersoft Studio v.6.0.3

Compiling the report gives me always the same error:

net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
 
calculator_rpt46visit_1426694094846_413337: 18: unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator 
 @ line 18, column 1.
 
calculator_rpt46visit_1426694094846_413337: 28: unable to resolve class JRFillParameter 
 @ line 28, column 5.
.....more stuff...
 
I already checked that groovy.all.2.0.1 jar is in the plugins folder.
Changing language from groovy to java is not a solution for me as almost all the reports are using groovy expressions.
I cannot understand what I'm doing wrong.
Bye
 
Antonio
strafico80's picture
Joined: Aug 26 2013 - 7:02am
Last seen: 2 years 10 months ago

I've been standing with similar problem, until not uninstalled previous versions of Jasper Studio and installed 6 0 4 one.

splintyg - 4 years 2 months ago

1 Answer:

0

Hi,
could you please open a bug related to this.
Also list the steps you performed when importing the reports inside Jaspersoft Studio (i.e. project creation with jars, etc.). Attach error log(s) and system details too.

If possible also attach a report with groovy that is giving you the issue.
I just tried to create a simple report with SampleDB and language Groovy. It compiled fine.

Thanks.
Regards,
Massimo.

mrabbi's picture
6890
Joined: Oct 31 2011 - 9:20am
Last seen: 3 days 13 hours ago
Feedback
randomness