js-install-ce.bat fails for Jasper Resport server 6.0.1

0

Hi, Installation of Jasper Report Server 6.0.1 fails when I try to execute the js-install-ce.bat. Below are the detail logs:

 

---------------------------------------------------------------------- Running JasperReports Server install script at 2015-03-12_05-23 ---------------------------------------------------------------------- [default] Running install-normal-ce Ant task ---------------------------------------------------------------------- Buildfile: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\build.xml [echo] Filtering properties (cleaning out blank spaces) [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] using settings file: C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default/maven_settings.xml gen-config: [echo] Regen config files if they have already been cleaned: [echo] currentConf= C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands test-ce-all-props: [echo] Checking properties: [echo] dbType=mysql [echo] dbHost=localhost [echo] dbUsername=root [echo] dbPassword=********** [echo] dbPort=3306 [echo] js.dbName=jasperserver [echo] sugarcrm.dbName=sugarcrm [echo] foodmart.dbName=foodmart [echo] webAppNameCE=jasperserver [echo] appServerType=tomcat7 [echo] appServerDir=C:\Program Files (x86)\Apache Software Foundation\Tomcat 7.0 check-dbtype-ce: test-appServerType-ce: do-install-upgrade-test: [echo] Checking DBMS host and port: [echo] About to validate host: localhost [echo] Host localhost is OK [echo] Done validating host: localhost [echo] About to validate port: localhost:3306 [echo] Port 3306 is OK [echo] Done validating port: localhost:3306 [echo] Validating administrative database connection at jdbc:mysql://localhost:3306/mysql. Phase: [test] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Connection OK [echo] Validating JasperServer database connection at jdbc:mysql://localhost:3306/jasperserver?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [test] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Connection OK do-pre-install-test: [echo] Validating FoodMart database connection at jdbc:mysql://localhost:3306/foodmart?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [test] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Failed to connect: Unknown database 'foodmart' [echo] Connection failed: [echo] SQLState: 42000 [echo] Vendor specific error code: 1049 [echo] Message: [Unknown database 'foodmart'] [echo] Database doesn't exist. Treating problem with JDBC connection as noncritical. Proceeding to next step [echo] Validating SugarCRM database connection at jdbc:mysql://localhost:3306/sugarcrm?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [test] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Failed to connect: Unknown database 'sugarcrm' [echo] Connection failed: [echo] SQLState: 42000 [echo] Vendor specific error code: 1049 [echo] Message: [Unknown database 'sugarcrm'] [echo] Database doesn't exist. Treating problem with JDBC connection as noncritical. Proceeding to next step pre-install-test-ce: recreate-js-db: [echo] Validating JasperServer database connection at jdbc:mysql://localhost:3306/jasperserver?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [before] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Connection OK [input] Database [jasperserver] already exists. Drop it and create new? WARNING: All existing data will be lost! This operation may not be rolled back. Enter 'y' to recreate or 'n' to skip this step. Default is 'n' (y, [n]) [echo] Filtering properties (cleaning out blank spaces) [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] using settings file: C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default/maven_settings.xml drop-js-db: [echo] Dropping database. js.dbName = jasperserver [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 62 rows affected [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Filtering properties (cleaning out blank spaces) [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] using settings file: C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default/maven_settings.xml create-js-db: [echo] Creating database, js.dbName = jasperserver, create database jasperserver character set utf8 [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 rows affected [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Validating JasperServer database connection at jdbc:mysql://localhost:3306/jasperserver?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [after] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Connection OK fill-js-ce-db-minimal: [echo] Filtering properties (cleaning out blank spaces) [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] using settings file: C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default/maven_settings.xml init-js-db-ce: [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing resource: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\install_resources\sql\mysql\js-create.ddl [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] Executing resource: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\install_resources\sql\mysql\quartz.ddl [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 0 rows affected [advanced-sql] 149 of 149 SQL statements executed successfully [echo] Filtering properties (cleaning out blank spaces) [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] Tomcat DBCP Factory: com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands [echo] chkIfPackageManagedTomcat: check if package managed tomcat [echo] using settings file: C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default/maven_settings.xml import-minimal-ce: [echo] [echo] Property values (in install.xml): [echo] archiveArg = --input-zip=C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/install_resources/export/js-catalog-minimal-ce.zip [echo] dbType = mysql [echo] jdbcJar = mysql-connector-java-5.1.22-bin.jar [echo] currentConf = C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/build_conf/default [echo] importExportConfig = C:/Jaspersoft/jasperreports-server-cp-6.0.1-bin/buildomatic/conf_source/ieCe [echo] [echo] Validating JasperServer database connection at jdbc:mysql://localhost:3306/jasperserver?useUnicode=true&characterEncoding=UTF-8&autoReconnect=true&autoReconnectForPools=true. Phase: [import-export-test] [echo] For JDBC driver the artifactId and version properties are set: [echo] maven.jdbc.artifactId=mysql-connector-java [echo] maven.jdbc.version=5.1.22-bin [echo] Specified JDBC driver jar exists [advanced-sql] Executing commands [advanced-sql] 1 of 1 SQL statements executed successfully'

[echo] Connection OK

[java] JVMJ9VM015W Initialization error for library j9gc26(2): Failed to instantiate heap; 2G requested [java] Error: Could not create the Java Virtual Machine. [java] Error: A fatal exception has occurred. Program will exit. BUILD FAILED C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\db-common.xml:929:

The following error occurred while executing this line: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\import-export.xml:277:

The following error occurred while executing this line: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\import-export.xml:158: Java returned: 1 Total time: 1 minute 7 seconds Checking Ant return code: OK ----------------------------------------------------------------------

khushboo_sangtani's picture
Joined: Mar 10 2015 - 5:19am
Last seen: 4 years 7 months ago
I think here is the main error, any help to fix this is much appreciated. [advanced-sql] 1 of 1 SQL statements executed successfully [echo] Connection OK [java] JVMJ9VM015W Initialization error for library j9gc26(2): Failed to instantiate heap; 2G requested [java] Error: Could not create the Java Virtual Machine. [java] Error: A fatal exception has occurred. Program will exit. BUILD FAILED C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\db-common.xml:929: The following error occurred while executing this line: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\import-export.xml:277: The following error occurred while executing this line: C:\Jaspersoft\jasperreports-server-cp-6.0.1-bin\buildomatic\bin\import-export.xml:158: Java returned: 1
khushboo_sangtani - 4 years 7 months ago

You probably need to uninstall postgresql completely and reinstall postgresql. That worked for me.

Reference: https://medium.com/@bitadj/completely-uninstall-and-reinstall-psql-on-osx-551390904b86

sewwandikaus.13 - 1 year 8 months ago

0 Answers:

No answers yet
Feedback