is it possible to run JasperServer on GlassFish 4 and JDK8?

0

We can't downgrade to Glass 3.1.2 because is doesn't support jdk8, and we have several project running with jdk8.

The only exception that we got when we try to deploy it, is:

DI deployment failure:WELD-001408 Unsatisfied dependencies for type [Set<Service>] with qualifiers [@Default] at injection point [[BackedAnnotatedParameter] Parameter 1 of [BackedAnnotatedConstructor] @Inject com.google.common.util.concurrent.ServiceManager(Set<Service>)]
org.jboss.weld.exceptions.DeploymentException: WELD-001408 Unsatisfied dependencies for type [Set<Service>] with qualifiers [@Default] at injection point [[BackedAnnotatedParameter] Parameter 1 of [BackedAnnotatedConstructor] @Inject com.google.common.util.concurrent.ServiceManager(Set<Service>)]
 at org.jboss.weld.bootstrap.Validator.validateInjectionPointForDeploymentProblems(Validator.java:403)

is there a solution?, someone could make JasperServer run with these settings?

firuzzz's picture
45
Joined: May 17 2012 - 5:03am
Last seen: 1 month 3 weeks ago

1 Answer:

0

Not sure about Glassfish Java 8 is not yet supported, for the supported platforms list check:  https://www.jaspersoft.com/sites/default/files/Jaspersoft%20Platform%20S...

marianol's picture
4545
Joined: Sep 13 2011 - 8:04am
Last seen: 10 months 3 weeks ago
Feedback
randomness