Excel Output : Ignore Pagination + One Page Per Sheet + Page Break Property Results into Identical Column Width in the Resulting Sheets

0

I have a report with the following layout:

[Section 1 - Summary that can span more than 1 A4 size paper on print]

[break]

[Section 2 - Details that can span more than 1 A4 size paper on print]

 

The report can be exported to PDF and Excel. PDF export was a breeze. 

For Excel export, I utilized ignore pagination, one page per sheet and page break properties. The resulting Excel document had two sheets but the column widths were identical. Ideally, since they are different sheets, I was expecting their column widths to be independent of each other. I tried removing the ignore pagination setting and the resulting Excel document had, as expected, more than two sheets but with different column widths (a surprise!).

 

I would like to know if there is a way to implement to restrict the Excel output to the two sheets/sections as designed but have independent columns widths from each other? Is this a bug in the implementation of the library? Or am I missing some setting here?

cutebluangel's picture
Joined: Sep 23 2012 - 8:45pm
Last seen: 3 months 4 weeks ago

1 Answer:

0

The links on the right side of my question lead me to the solution.

I did not use anymore the xls.break.after.row property. Instead, I used the page break element (as I was doing to PDF output) and set the "net.sf.jasperreports.page.break.no.pagination" to apply in the actual report template. The setting does not seem to be honored when set programmatically.

cutebluangel's picture
Joined: Sep 23 2012 - 8:45pm
Last seen: 3 months 4 weeks ago
Feedback
randomness