Jasper Report Custom Visualization Problem

0

I am having following problem while running a custom visualization sample report from the following URL.

Problem: net.sf.jasperreports.engine.JRException: net.sf.jasperreports.engine.JRRuntimeException: No script provided for the Custom Visualization component.

URL: https://community.jaspersoft.com/wiki/custom-visualization-component-jas...

I am using JasperSoft Studio 6.0.1 in windows environment. I set up the jasperStudio properties paths according to the wiki. For example: C:/dev/java/workspace/MyReports/scripts/scripts/highcharts/highcharts-3.0.7.src.js   

I have tried with either "file://" or without it. Also tried both "/" and "\" in the path strings and none of them works.

Can anybody help me please? 

- Thanks in advance for any help or comments!! 

mustafa_2's picture
Joined: Jan 12 2015 - 6:43am
Last seen: 4 years 5 months ago

1 Answer:

2

The Custom Visualization Component has changed in 6.0.1.

To get a working starting point do this: File -> New -> Other, then select Jaspersoft Studio -> Custom Visualization Component. Click Next, choose one of the provided samples, give it a name, and click through the rest.

You should now have a new project in your workspace with one jrxml and several Javascript and maybe some CSS files. To preview the jrxml you need to compile everything first. For that, right-click on "build.js" and select "Build Component". Then preview the report. You have to compile every time you change something in the Javascript.

Once you have this running, you can put in your own code.

cwurm's picture
27
Joined: Jul 28 2014 - 8:45am
Last seen: 4 years 5 months ago

Thanks a lot. I followed your solution, created a separate project with a sample (d3). It works fine. Later I copied all the files to my existing project, and it works as well. However, I could not still run my samples (downloaded from the URL). I changed the build.js accordingly, but still not working. I am trying to figure out what I missed. Thanks again.

mustafa_2 - 4 years 6 months ago
Feedback
randomness