How to get iReport to work on Apple

0

I just downloaded the 5.6 version of iReport (dmg) and installed on my iMac (mid 2010)

The application appears in my applicatrions list but when I select the application, nothing happens.

Any ideas?

Jim P.

jkpalmer52's picture
Joined: Jan 7 2015 - 7:55am
Last seen: 3 years 6 months ago

Same problems I am facing 

what version of java are you using ?

Ankur Gupta - 4 years 9 months ago

I just ran a Java update and I'm running Java 8 UPdate 25.

 

 

jkpalmer52 - 4 years 9 months ago

I believe you need to back off of Java 8.

$ java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
$ which java
/usr/bin/java
$

If I run across more info, I'll post it here.

djohnson53 - 4 years 9 months ago
show 3 more...

When I run java -version from Terminal, I receive:

James-Palmers-iMac-27:~ jkpalmer$ java -version

 

No Java runtime present, requesting install. 

Do I need to install a JDK or JRE?

I'm not sure how to "back off" Java 8....

 

jkpalmer52 - 4 years 9 months ago

I believe that the JDK is what you want.   Try getting it to see Java 8 and see if it works.  If not, then figure out how to rev back the version.

djohnson53 - 4 years 9 months ago

Any more information on this since last post?

I'm running OS X Yosemite 10.10.2.  When I attempt to execute "java -version" or "java **ANYTHING**" I get the message:
"To use the 'java' command-line tool you need to install a JDK".  The More Info button takes me to:
http://www.oracle.com/technetwork/java/javase/downloads/

There is no Java control panel item I can find to get the version.

Is there a simpler way to get the darn iReport to work on Apple.  I just want to make reports.

chris.davis_2 - 4 years 5 months ago

0 Answers:

No answers yet
Feedback
randomness