Empty cell in Excel when overflow

0

Hi,

When I am trying to export report to xls format I get empty cells, if textfield value overflow.

I set textfiled property stretch with overflow to the true and added these properties to report:

<property name="net.sf.jasperreports.print.keep.full.text" value="true"/>
<property name="net.sf.jasperreports.export.xls.detect.cell.type" value="true"/>
<property name="net.sf.jasperreports.export.xls.wrap.text" value="false"/>
<property name="net.sf.jasperreports.export.xls.auto.fit.row" value="true"/>
<property name="net.sf.jasperreports.export.xls.auto.fit.column" value="true"/>
 
But it doesn't help!
 
Does anybody know how to solve this issue?
pashab's picture
3
Joined: Nov 3 2014 - 12:12pm
Last seen: 4 years 10 months ago

2 Answers:

0

try the following:

http://jasperreports.sourceforge.net/config.reference.html#net.sf.jasper...

 

 

net.sf.jasperreports.export.xls.remove.empty.space.between.rows = true

 

net.sf.jasperreports.export.xls.remove.empty.space.between.columns = true

darth_fader's picture
Joined: Mar 7 2010 - 9:45pm
Last seen: 2 months 2 weeks ago

Hi gertbeedfrobe,
Thanks for your response.
But it is not exactly that I mean
I have problem during the export to excel when textfiled have big word, that does not fit within the boundaries of the field. Then this value is losted and is not contained in cell.
Does jasperreports have some settings for hyphenation?

In HTML it also doesn't work as I expected:
the field stretches horizontally and pushes the columns on the right, over another fields

pashab - 4 years 10 months ago
0

This is what I get:

http://c2n.me/39cbljj - link to screenshot

Does anybody know to solve this issue, please help?

pashab's picture
3
Joined: Nov 3 2014 - 12:12pm
Last seen: 4 years 10 months ago

On the Detail properties, set the Split Type to 'Prevent'. On the field properties, set Stretch Type to 'No stretch'.

janiesprenger - 4 years 7 months ago
Feedback
randomness