JS Reporting and Analytics for AWS


I recently launched an JS reporting instance via Cloudformation. All went well. Issue I hit was: Exception occurred during AWS data source recovery: /organizations/xxxxx. The AWS data source can not be recovered automatically, because your JasperReports Server and database instance are not located in the same VPC

The instance launched in the Default VPC, which we don't use. Can I either updated the CF script or manually launch  the JS instance into my preferred VPC/subnet?
jrey's picture
Joined: Sep 15 2014 - 8:11pm
Last seen: 9 years 2 weeks ago

2 Answers:

Yes you will have to launch you instance manually to be able to add it to the correct VPC and subnet and then do not forget to follow the instrauctions at the very bottom of this page http://community.jaspersoft.com/jaspersoft-aws/launch to setup the IAM Role the IAM user and the securiti groups so you can use the DB autodiscovery feature

marianol's picture
Joined: Sep 13 2011 - 8:04am
Last seen: 4 years 12 months ago

Thanks. It's worked....kind of. I can now see the RDS instances, but when 


I'm now receiveing this error

Exception occurred during AWS data source recovery: /organizations/xxxxx. Status Code: 400, AWS Service: AmazonEC2, AWS Request ID: 36b1db9e-5801-4d76-92ec-6f8981f23a27, AWS Error Code: InvalidVpcID.NotFound, AWS Error Message: The vpc ID 'vpc-0xxxx' does not exist 

It's the same error as was posted here: https://community.jaspersoft.com/questions/841370/vpc-does-not-exist-err...

Any idea?

Thanks again



jrey's picture
Joined: Sep 15 2014 - 8:11pm
Last seen: 9 years 2 weeks ago

There are now cloud formation templates that you may launch into a VPC (2nd tab page):

alampitt - 8 years 11 months ago