JasperReports 5.6: Error Saving Domain

0

Hello all,

After updating JRS to 5.6, any attempt to save (submit) even an existing sample domain will fail with the following error message:

An error occurred while validating the Domain. Examine input data and save again.

Note that NO changes were made to the domain: I simply attempted to save (submit) that domain.

To repro:

  1. In JRS, at the home screen, select View list from the Domains section
  2. Select any existing sample domain (e.g, Supermart Domain)
  3. Right click on that domain and select Edit
  4. On the Edit Domain screen, make no changes, and click the Submit button.
  5. Note the error message (noted above).

Please advise on how to better debug this issue.

Thanks 

richbl's picture
39
Joined: May 22 2014 - 7:14pm
Last seen: 2 years 11 months ago

I have tried reproducing the error by following your procedure and everything worked fine. Have you used the export/import functions? I had the same issue when I imported the data from my 5.5 to 5.6, but when using a clean install of 5.6 it works like it should.

One thing that I noted that might have something to do with this is that the domains (even the supermart ones) were created in may 30th, but last modified in march 29th. This might create some issues in the checksums and verifications, but I'm only assuming this.

I am killing my 5.6 instance and reverting to 5.6, sicne I cannot put the time to creating all my reports again, but I expect at least an acknowledgement from Tibco/Jaspersoft relating to this issue, since you seem to be the 3rd user with this problem. 

daniel_17 - 6 years 2 weeks ago

2 Answers:

0

Hi,

I have brought this to the attention of engineering management.  There may be a workaround - when I have the details, I will post it ASAP. 

My apologies to everyone who has encountered this issue.

Eliza 

elizam's picture
5051
Joined: Mar 5 2012 - 9:19am
Last seen: 6 days 7 hours ago

Be sure to contact everyone that had this issue when a solution is found, since you only seem to have commented on the most recent question...

daniel_17 - 6 years 1 week ago

daniel,

If you are a commercial user, and want to put us on the spot for an answer, you need to submit the issue to Customer Support.

Please remember that, for commercial customers, these Question/Answer forums are not a substitute for submitting an issue to Customer Support. This is a requirement if you need a hotfix to a particular problem.

Workarounds are something we would very likely post as a Wiki article here on the community.jaspersoft.com. Many of our Troubleshooting Wiki articles originate as Customer Support Issues. But we can't guarantee that we can find and contact 'everyone that had this issue'. We can guarantee that we will do our level best to provide timely and accurate information as Eliza does, and communicate as effectively as possible.

djohnson53 - 6 years 1 week ago
0

All,

I have an answer of sorts... rather an observation that AT LEAST permits a short-term workaround (or a clue to a fix).

From conversations with JS folks--and this is my subjective interpretation--this problem will happen when a user is NOT tagged with "organization_1." If you look in Manage/Users, you'll see a default set of users with this moniker. I don't know what this tag is or how it was created. And there's no way to edit this tag, or manage this tag for "real" users. I suspect that this tag was generated as a side effect of the multi-tenancy feature which is an optional purchase of the JRS Professional edition...

In the short term, here's the work-around that appears to work for me:

  1. Log in as yourself (you will need ROLE-ADMINSTRATOR role set, as you'll need to log in through another user).
  2. Once logged in go to Manage/Users. You should see a handful of users with the mysterious "organization_1" tag (e.g., CaliforniaUser, demo, jasperadmin, and joeuser).
  3. Click on the jasperadmin user. Note the right panel displays user details.
  4. Click Login as User. In the upper right you'll see "[your username] as jasperadmin User" displayed.

At this point, you SHOULD have the ability to create and edit Domains as expected.

It's still unclear as to the implications of creating/editing/managing domains that have been created/edited by another user. So, caveat emptor.

Rich

richbl's picture
39
Joined: May 22 2014 - 7:14pm
Last seen: 2 years 11 months ago

Thanks for posting the above workaround. A defect against JRS 5.6 has been filed, #38332. For search/reference the stacktrace is:
java.lang.NullPointerException at org.hibernate.criterion.IlikeExpression.getTypedValues(IlikeExpression.java:69) at org.hibernate.loader.criteria.CriteriaQueryTranslator.getQueryParameters(CriteriaQueryTranslator.java:274) at org.hibernate.loader.criteria.CriteriaLoader.list(CriteriaLoader.java:118) at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1597) at

ghudson_1 - 6 years 1 week ago

A quick edit to my above observation/workaround.

It turns out that if you create a user in the \root folder, that user does not get the "organization_1" assignment (read: member of group Organization). This lack of organization identity may be the cause for executing this issue, and explains why only some folks are exercising this condition.

Simplifying: if your user is associated with an organization, this issue is not (or, does not appear to get) exercised.

richbl - 6 years 1 week ago

Thanks for your help Greg.

richbl - 6 years 1 week ago
Feedback