Jasper server 5.6 - JNDIResourceProvider,localhost-startStop-1:75 - error closing context javax.naming.OperationNotSupportedException: Context is read only

1

Hi!

Just installed Jasper Server 5.6 (with bundled postgres and tomcat) on Win 8.1 64 bit, but the login page can't load (http 500 and Internal server error occurred. Please contact your system administrator. Details: java.lang.NullPointerException). Installer completed without any problem, the db is accessible, and contains 4 databases (foodmart, jasperserver, postgres, sugarcrm)

jasperreportstomcat-stdout.2014-07-23.log has a couple of exceptions (attached the full file), the first error is this:

ERROR JNDIResourceProvider,localhost-startStop-1:75 - error closing context
javax.naming.OperationNotSupportedException: Context is read only
    at org.apache.naming.NamingContext.checkWritable(NamingContext.java:962)
    at org.apache.naming.NamingContext.close(NamingContext.java:762) ...

The second one:

ERROR ThemeTag,http-apr-8081-exec-8:86 -
java.lang.NullPointerException
    at com.jaspersoft.jasperserver.war.themes.MTThemeResolver.getRootActive(MTThemeResolver.java:76)
    at com.jaspersoft.jasperserver.war.themes.MTThemeResolver.resolveThemeName(MTThemeResolver.java:50)
    at com.jaspersoft.jasperserver.war.themes.JSThemeResolver.resolveThemeName(JSThemeResolver.java:69)
    at org.springframework.web.servlet.support.RequestContextUtils.getTheme(RequestContextUtils.java:151) ...

and also this one:

ERROR RenderViewExceptionInterceptor,http-apr-8081-exec-8:38 - Internal server error occurred. Please contact your system administrator.
org.apache.jasper.JasperException: An exception occurred processing JSP page /WEB-INF/decorators/decorator.jsp at line 46

43:         <!--
44:         <meta http-equiv="X-UA-Compatible" content="IE=8"/>
45:         -->
46:         <link rel="shortcut icon" href='${pageContext.request.contextPath}/<spring:theme code="images/favicon.ico" />' />
47:
48:         <!--
49:             <link rel="shortcut icon" href="favicon.ico" />


Stacktrace:
    at org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:568)
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:470)
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305) ...

 

Any idea? (already tried to uninstall + reinstall, same symptoms after first install)

java version, if it may matter:
  java version "1.7.0_65"
  Java(TM) SE Runtime Environment (build 1.7.0_65-b19)
  Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

akoslukacs42's picture
Joined: Jul 2 2014 - 4:12am
Last seen: 4 years 10 months ago

4 Answers:

0

Did you use Window Explorer to extract JasperReport Server files? If so, that may be the problem. Windows sometimes doesn't extract all the files in zip. Try using something like 7zip:

http://www.7-zip.org/

hozawa's picture
54050
Joined: Apr 24 2010 - 4:31pm
Last seen: 6 months 14 hours ago

Used the installer (jasperreports-server-cp-5.6.0-windows-x64-installer.exe). This same installer worked just fine on another Win7 machine, and a Win2012 server.

akoslukacs42 - 5 years 4 months ago

Hi am facing the same issue.Do you have any recommendation to fix this issue ?

rajesh12perfect - 4 years 10 months ago
0

Had a very similar error the first time I tried to bring up the login page after a fresh binary install on Win 8.1.  Refreshing the login page worked, but now I get similar errors trying to login as jasperadmin.

Both errors involve this:

java.io.IOException: tmpFile.renameTo(classFile) failed

somewhere in the stack trace.  I wonder if there are directory permissions issues with Win 8.1.

Please keep us updated if you solve your problem, and I will, too.

mtvessel85's picture
Joined: Jul 24 2014 - 8:04pm
Last seen: 5 years 4 months ago

...and trying to login multiple times eventually works. I think maybe there's just a problem the first time I access something, because it has to generate things on the fly. (?)

mtvessel85 - 5 years 4 months ago

Well, tried to change the service users to a specific user, that explicitly had full control permission on the jasper directories, but no luck so far... (for me, the login page does not load even after multiple page refreshes)

akoslukacs42 - 5 years 4 months ago

Hi ,
Can anybody tell me if this was fixed ? if so please let me know the steps. am also facing the same issue.

rajesh12perfect - 4 years 10 months ago
0

The same in over Centos 6.3 ... how can I solved this ???

hectormero's picture
Joined: Sep 3 2013 - 9:43am
Last seen: 5 years 2 months ago
0

I encountered the same error. I found the solution here: http://community.jaspersoft.com/questions/801709/getting-internal-server-error-while-login-jasperserver-link. The problem was that the JIFILERESOURCE had not been loaded.

jsingy's picture
2
Joined: Apr 18 2015 - 10:15am
Last seen: 1 year 10 months ago
Feedback
randomness